[ОТВЕТИТЬ]
Опции темы
16.11.2015 16:32  
cps-retail
Доброго времени суток!

На "стенде" обновляю УКМ, с 49.5 до 67, сам сервер обновляется нормально, но предварительная загрузка на кассы (когда сервер еще 49.5) проходит только до 51 версии (видимо причина в маске файлов обновления). Правильно ли я понимаю, сначала должен загрузить на кассы обновления до 51, обновить сервер с 49.5 до 67, а потом попытаться прогрузить обновления с 51 по 67 и обновить их? Может тогда у кого есть готовый скрипт для полного копирования обновлений по списку касс?

Заранее спасибо!
 
16.11.2015 16:37  
Mtirt
Лучше сначала и сервер и кассы до 51 версии, а потом - с 51 и дальше.
 
16.11.2015 16:57  
cps-retail
лицензии на 51 нет, да и хотелось бы за раз (если через SSH принудительно копирую с 51 до 67 то все обновление на кассе с 49.5 до 67 проходит в штатном режиме)
 
16.11.2015 18:29  
Starter
У нас кассы в несколько этапов обновлялись. Автоматом. Т.е. сперва обновляли сервер, потом ставили флажок автообновления и все. Правда, кассы обновлялись через 2 промежуточных версии. Обновляется, потом запускается укмклиент, потом минут через 5 обновляется дальше. Процесс занимал пару часов. Обновляли с 49сп6 до 66.
 
"Спасибо" Starter от:
02.06.2016 15:34  
TEHb2
Цитата:
Сообщение от Starter
Обновляли с 49сп6 до 66.
Вот и у меня появилась необходимость обновится с 49сп6 до крайней 70-й.
Как лучше собрать файлы обновления, чтобы было меньше всего этапов?

А я, в общем то, никогда УКМ не обновлял.
И вот у меня проблема. После запуска в логе обновления такое:

2016/06/02 17:27:31|Update sequence build for ops packages started
2016/06/02 17:27:31|
2016/06/02 17:27:31|---- NON CRITICAL ERROR ----
2016/06/02 17:27:31|
2016/06/02 17:27:31|FindPackages() failed. SelectPackagesForUpgrade() failed. SelectOpsPackages() failed: ??N??°N?N?????N??? ???°???µN? ???±???????»?µ?????? ???»N? N?N?N??°???????»?µ???????? ???µN?N????? ?????? ???µ ???°?????µ??
2016/06/02 17:27:31|UPDATE FAILED
2016/06/02 17:27:31|Removing UPDATE_IN_PROGRESS
2016/06/02 17:27:31|==== StartStopPrograms(postupdate) begin
2016/06/02 17:27:31| Starting services
2016/06/02 17:27:31|Trying to start service "MySql"
2016/06/02 17:27:31|Service "MySql" is already running
2016/06/02 17:27:31|Service "MySql" started
2016/06/02 17:27:31|Sleeping for 30 sec
2016/06/02 17:28:01|Trying to start service "UkmService"
2016/06/02 17:28:01|Service "UkmService" is already running
2016/06/02 17:28:01|Service "UkmService" started
2016/06/02 17:28:01|Sleeping for 30 sec
2016/06/02 17:28:31|Trying to start service "Apache2"
2016/06/02 17:28:31|Service "Apache2" is already running
2016/06/02 17:28:31|Service "Apache2" started
2016/06/02 17:28:31|Sleeping for 30 sec
2016/06/02 17:29:01|==== StartStopPrograms(postupdate) end
2016/06/02 17:29:01|===> ukmupman WORK FINISHED.
2016/06/02 17:29:01|

Не понятно в какой кодировке ошибка.
С чем может быть связано?
 
02.06.2016 15:48  
m1n1mal
Не помешало бы наличие следующих лог файлов ukmupman.log и ukmup.log
 
02.06.2016 16:16  
TEHb2
Ну так это как раз из этих логов.
 
02.06.2016 16:19  
m1n1mal
т.е. это все что присутствует в логе в момент запуска обновления?
 
02.06.2016 16:26  
whitewizard
Видимо, не туда поклал файлы обновления
 
02.06.2016 16:36  
m1n1mal
Действительно, проверьте наличие файлов обновлений в каталоге: c:\Program Files\ukmserver\ukmupman\update\
скачанные архивы с FTP СервисПлюс должны быть предварительно распакованы, перед тем как закидывать в данный каталог.
 
 


Опции темы



Часовой пояс GMT +3, время: 14:42.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.