[ОТВЕТИТЬ]
Опции темы
15.02.2016 18:25  
Tigra_N
Знаю, что открывал тему, но ее закрыли из-за того, что я нарушил правила форума. Прошу прощения у модераторов и участников форума, я не со зла. Надеюсь, больше не повторится! Почему "надеюсь"? Потому, что я даже не знал о таком правиле.


Снова опишу проблему, надеюсь отзоветесь:

Мой терминал работает на Windows CE. Для нее написана программа сбора данных на базе Superkit, которая выгружает/загружает файл формата CSV. Файл Импорта (входной) , формат файла – CSV, разделитель «;» Имя по-умолчанию SCANIN.DAT , путь к файлу настраивается в программе.

Структура файла следующая:
P;8594404110110;Վաֆլի Գրանդ Քենդի Մու-Մու կգ;0;1;4605664000197;;шт //<ШТРИХКОД> - максимально 64 символа; <НАЗВАНИЕ> - максимально 128 символов, сейчас
назавание на армянском; <ЦЕНА> - CURRENCY, разделитель целой и дробной части «.»; <КОЛИЧЕСТВО> - FLOAT; <ССЫЛОЧНЫЙ ШК ДЛЯ ГРУППОВЫХ ТОВАРОВ> - максимально 64 символа, последнее значение не используется, но должно присутствовать; ;;кг - нет описания, но без этого окончания не будет работать.

Файл Экспорта (выходной) , формат файла – CSV, разделитель «;» Имя по-умолчанию SCANOUT.DAT, путь к файлу настраивается в программе.
Структура файла следующая:
P;4820080724322;2.000 //Префикс записи «P»; <ШТРИХКОД> - 64 символа; <КОЛИЧЕСТВО> - FLOAT.

Также выкладываю файл выгрузки конфигурации:
Вложения
Тип файла: zip 1cv8.zip (21.20 Мб, 57 просмотров)
 
15.02.2016 18:46  
KirillHome
Zip-архив не читается.

Ладно, фиг бы с ним - скриншотов с конфигуратора будет достаточно.

Собственно, вопросы для начала:
Что такое "штрихкод" в данной конфигурации?
Справочник, регистр сведений? Характеристика товара? Что-то ещё?

Тот же самый вопрос о "Ссылочный шк для групповых товаров".
 
15.02.2016 18:59  
Tigra_N
Перезалил файл, у меня на компьютере все открывается.
В конфигурации штрих коды хранятся в регистре сведений (ШтрихкодыНоменклатуры).
Вложения
Тип файла: rar 1cv8.part1.rar (45.00 Мб, 55 просмотров)
Тип файла: rar 1cv8.part2.rar (21.79 Мб, 59 просмотров)
 
15.02.2016 19:03  
Tigra_N
Цитата:
Сообщение от KirillHome
Тот же самый вопрос о "Ссылочный шк для групповых товаров".
Не имею представления где хранятся значения, но пока этот параметр можно не учитывать.
 
15.02.2016 19:25  
KirillHome
Цитата:
Сообщение от Tigra_N
Перезалил файл, у меня на компьютере все открывается.
В конфигурации штрих коды хранятся в регистре сведений (ШтрихкодыНоменклатуры).
Скачал, открыл в 1с.
Смотрю.
Если всё будет нормально - завтра к вечеру будет первая редакция выгрузки из 1с.

Я правильно понимаю, что надо будет предусмотреть три режима выгрузки:
1) Все товары
2) Товары определённой группы
3) Просто определённые товары
 
"Спасибо" KirillHome от:
15.02.2016 20:05  
KirillHome
Посмотрел на это на всё.

По сути дела, надо изменить чуть-чуть обработку "УправлениеТСД" на то, что бы она не закачивала напрямую данные в ТСД (не считывала напрямую данные из ТСД), а выводила данные в файл или читала из файла.

Вот, к примеру, "кусок для выгрузки"
Код:
	Для Каждого ТекСтрока Из ТаблицаВыгружаемыхТоваров Цикл
		
		Наименование = ТекСтрока.НаименованиеТовара;
		Если НЕ ПустаяСтрока(ТекСтрока.НаименованиеХарактеристики) Тогда
			Наименование = Наименование + " (" + ТекСтрока.НаименованиеХарактеристики + ")";
		КонецЕсли;
		
		Наименование = Лев(Наименование, 39);
		
		НоваяСтрока = Новый Структура;
		
		Если ТекСтрока.ШтрихкодЦифровой Тогда
			Если ТекСтрока.Штрихкод > 99999 Тогда
				ЕстьВесовыеТоварыСДлинойКодаБольше5 = Истина;
				Продолжить;
			Иначе	
				НоваяСтрока.Вставить("Штрихкод", Формат(ТекСтрока.Штрихкод, "ЧЦ=5; ЧВН=; ЧГ="));
			КонецЕсли;
		Иначе 
			НоваяСтрока.Вставить("Штрихкод", ТекСтрока.Штрихкод);
		КонецЕсли;
		
		НоваяСтрока.Вставить("Наименование", Наименование);
		НоваяСтрока.Вставить("Цена", Формат(ТекСтрока.Цена, "ЧДЦ=2; ЧН=0,00; ЧГ="));
		НоваяСтрока.Вставить("Код", ТекСтрока.Код);
		
		Результат.Добавить(НоваяСтрока);
		
	КонецЦикла;
Т.е. выводят - Штрихкод, наименование, цена, код
Нужно добавить остаток (т.к. склад есть - то это не проблема) и убрать код.

Так?
 
"Спасибо" KirillHome от:
15.02.2016 22:59  
Tigra_N
Цитата:
Сообщение от KirillHome
По сути дела, надо изменить чуть-чуть обработку "УправлениеТСД" на то, что бы она не закачивала напрямую данные в ТСД (не считывала напрямую данные из ТСД), а выводила данные в файл или читала из файла.

Т.е. выводят - Штрихкод, наименование, цена, код
Нужно добавить остаток (т.к. склад есть - то это не проблема) и убрать код.

Так?
да, именно так!
я не программирую, тем более в 1С, поэтому не могу сразу отвечать на вопросы. приходится изучать и отвечать
 
15.02.2016 23:05  
Tigra_N
думаю, в обработке УправлениеТСД, надо поменять поле "Модель ТСД" на "Путь к файлу", Категорию цен оставить так же, а поля Контрагент и Склад убрать вообще потому, что они нужны при работе с MobileLogistic, а у нас переписанная SuperKit.

Цитата:
Я правильно понимаю, что надо будет предусмотреть три режима выгрузки:
1) Все товары
2) Товары определённой группы
3) Просто определённые товары
было бы отлично
 
15.02.2016 23:17  
KirillHome
Цитата:
Сообщение от Tigra_N
да, именно так!
я не программирую, тем более в 1С, поэтому не могу сразу отвечать на вопросы. приходится изучать и отвечать
А вроде несколько месяцев назад собирался
Цитата:
Сообщение от Tigra_N
тогда прошу совета по онлайн курсу для сдачи экзамена на 1С Професионал. Желательно бесплатного, можно и с торент трекеров.
 
16.02.2016 02:09  
KirillHome
Нулевой вариант (прикреплён)

Нужно проверить, что правильно показывает наименование, цену, остаток.
Никаких проверок пока нет, поэтому:
1) Запускаем через "Файл" - "Открыть"
2) Заполняем поля "Организация", "Склад", "Категория цен"
3) На вкладке "Товары" - "Заполнить" - "Добавить товары по группе", выбираем нужную группу (наверное, можно и все товары - но, думая, это будет медленнее)
По идее - должны получить список товаров выбранной группы с указанными ценами и остатками на выбранном складе.

Если организаций/складов/цен несколько - имеет смысл проверить и на них (пока выбор другого реквизита - Организация, склад, цена - не приводит к правильному перезаполнению табличной части, так что - изменяем реквизиты и выбираем нужную группу, говоря - "Очистить данные").

Если в этой "арифметике" всё верно - пойду дальше (увы, не могу проверить сам. Не удаётся провести документы оприходования - похоже, многое зашито на ключ).
Вложения
Тип файла: zip УправлениеТСДExt.zip (53.8 Кб, 53 просмотров)
 
 


Опции темы



Часовой пояс GMT +3, время: 15:01.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.