[ОТВЕТИТЬ]
16.03.2016 08:34
aldemko
 
В общем в одной из тем пытался изменить php-fpm на php-fpm56
у результате не работают сайты(

https://olegon.ru/showthread.php?p=252873#post252873

сайт открывается по /index.html
по просто адресу ошибка 502
index.php тоже не открывается 502 ошибка
пробовал запускать перезапускать сервисы и сервер
в логах ошибки
https://olegon.ru/showpost.php?p=252873&postcount=26

https://olegon.ru/showpost.php?p=249538&postcount=22
выполнил команду сейчас вот такие данные:

cat /usr/local/apps/nginx/etc/conf.d/common:
cat /usr/local/apps/nginx/etc/conf.d/common
# Redirect server error pages to the static pages
error_page 500 502 504 /500.html;
location = /500.html {
root /usr/local/apps/nginx/etc/conf.d;
internal;
}

error_page 404 /404.html;
location = /404.html {
root /usr/local/apps/nginx/etc/conf.d;
internal;
}

error_page 497 /497.html;
location = /497.html {
root /usr/local/apps/nginx/etc/conf.d;
internal;
}

error_page 555 /555.html;
location = /555.html {
root /usr/local/apps/nginx/etc/conf.d;
internal;
}

location @maintenance {
root /usr/local/apps/nginx/etc/conf.d;
rewrite ^(.*)$ /noindex.html break;
}

# Pass the INDEX.PHP script to FastCGI server listening on 127.0.0.1:9178
location = / {
fastcgi_read_timeout 3600;
try_files $uri /index.php /index.html @maintenance;
fastcgi_pass 127.0.0.1:9001;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
include fastcgi_params;
}

# For userdir files
location ~* ^/~(.+?)(/.*\.php)$ {

alias /home/$1/public_html$2;
fastcgi_pass 127.0.0.1:9001;
include fastcgi_params;
fastcgi_param SCRIPT_FILENAME $request_filename;
}

# For userdir files
location ~ ^/~(.+?)(/.*)?$ {
alias /home/$1/public_html$2;
index index.html index.htm index.php;
autoindex on;
}

# To catch index.php by default
location ~ (index.php|/)$ {
fastcgi_read_timeout 3600;
try_files $uri $uri/index.php $uri/index.html;
fastcgi_pass 127.0.0.1:9001;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
include fastcgi_params;
}

# Pass the regular PHP scripts to FastCGI server listening on 127.0.0.1:9179
location ~ \.php$ {
fastcgi_read_timeout 3600;
try_files $uri =404;
fastcgi_pass 127.0.0.1:9001;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
include fastcgi_params;
}

location ~ \.pl|cgi$ {
try_files $uri =404;
gzip off;
fastcgi_pass 127.0.0.1:8999;
fastcgi_index index.cgi;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param SCRIPT_NAME $fastcgi_script_name;
include fastcgi_params;
16.03.2016 08:59
OlegON
 
Смотри, суть технологии.
Работает веб-сервер, на 80 порту и, если включен HTTPS, на 443.
Веб-сервер отдает статику, файлики html и прочие картинки.
Если веб-сервер видит .php, он отдает его прослушивателю для fastcgi на порту 9001, если cgi и pl - на порту 8999.
К конфигу очень много вопросов, сразу видно, что этот мусор нагенерен автоматом, но сейчас не о нем.
php-fpm должен слушать на 9001. а у тебя не слушает. лезь в конфиг php-fpm (не php) и настрой правильный порт.
16.03.2016 09:21
aldemko
 
Я нашел упоминания о php-fpm
по адресу /etc/php-fpm.d/
в нем
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.

в нем есть строка listen = 127.0.0.1:9000
Заменил на 9001
перезагрузил
результат прежний
или не там ищу ?

еще вот что
SQL код:
 service nginx restart
nginx
: [warnconflicting server name "sorokadv.ru" on 0.0.0.0:80ignored
nginx
: [warnconflicting server name "www.sorokadv.ru" on 0.0.0.0:80ignored
nginx
: [warnconflicting server name "bezzapaha.ru" on 0.0.0.0:80ignored
nginx
: [warnconflicting server name "www.bezzapaha.ru" on 0.0.0.0:80ignored
Stopping nginx
: [ OK ]
Starting nginxnginx: [warnconflicting server name "sorokadv.ru" on 0.0.0.0:80ignored
nginx
: [warnconflicting server name "www.sorokadv.ru" on 0.0.0.0:80ignored
nginx
: [warnconflicting server name "bezzapaha.ru" on 0.0.0.0:80ignored
nginx
: [warnconflicting server name "www.bezzapaha.ru" on 0.0.0.0:80ignored
OK 
16.03.2016 09:37
OlegON
 
Ты опять мечешься (кстати, это не SQL код ни разу), не решай все ошибки сразу.
Судя по всему, твои игры через веб-конфигуратор закончились плохо и он насвинячил несколько записей сразу.
Выкинь конфиг nginx и напиши новый сам, убедись, что вся статика и phpinfo-файл нормально работают.
Потом перейдешь к поиску, какой же у тебя php-fpm запускается и какой конфиг он использует.
Бросай ребутиться по любому поводу.
16.03.2016 09:45
aldemko
 
Да не делал я ничего через панель давно
сегодня в putty сидел с php-fpm крутил
откуда вообще они взялись, просто хотел же вместо php 5.3 использовать 5,6
я даже не знаю сейчас с какого файла начать, что туда писать что бы хотя бы вернуть до прежних результатов
16.03.2016 09:47
OlegON
 
А бекапы исправляемых файлов ты до этого момента не делал?
16.03.2016 09:53
aldemko
 
Так файлы то у меня все есть и конфиги есть доменов
только я сейчас посмотрел - они не тронуты - и как были так и прописаны
по адресу /usr/local/apps/ngnix/etx/conf.d/*.conf - вместо * каждый конфиг на свой домен
16.03.2016 10:33
aldemko
 
Мне сначала нужно с Ngnix разобраться что бы сайты хоть как то работали ?
или с php-fpm ?
не могу понять просто
16.03.2016 10:48
OlegON
 
Цитата:
OlegON Ты опять мечешься (кстати, это не SQL код ни разу), не решай все ошибки сразу.
...
Выкинь конфиг nginx и напиши новый сам, убедись, что вся статика и phpinfo-файл нормально работают.
Потом перейдешь к поиску, какой же у тебя php-fpm запускается и какой конфиг он использует.
Я же все написал...
16.03.2016 12:17
aldemko
 
Я пока не уверен что поступил правильно
в общем через панель вебузо я удалил nginx (через не го я и устанавливал)
попробовал повторно установить через панель, пишет мол надо бы лицензию по выше класса
погуглил и решил установить через пути
команда yum install nginx не помогла - что то он не смог найти
я создал (погуглил и нашел) файл /etc/yum.repos.d/nginx.repo
с содержимым
Код:
[nginx]
name=nginx repo
baseurl=http://nginx.org/packages/centos/6/$basearch/
gpgcheck=0
enabled=1
затем написал yum install nginx
согласился с установкой
и теперь у меня вместо 502 ошибки Welcome to nginx!
я на правильном пути ?

(блин только теперь я не смогу управлять ним с панели - его там нет в списке сервисов - ну может и к лучшему)


PS только теперь не могу найти где править его конфиги - для хостов
по прежнему пути пусто совсем, а он же какую-то страницу открывает


А все - теперь он не в app
а в /etc/nginx - как и по всех справочных материалах и форумах


Все сделал
вписал свой конфиг
опять ошибка 502 (


Я создал отдельный файл конфига или нужно в default вписывать ?
или вообще не туда пишу

Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
Миниатюры
Нажмите на изображение для увеличения
Название: Снимок.JPG
Просмотров: 59
Размер:	21.6 Кб
ID:	7110  
16.03.2016 12:47
aldemko
 
В общем первые результаты но пока не очень утешительные
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
16.03.2016 13:08
aldemko
 
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
Миниатюры
Нажмите на изображение для увеличения
Название: php.JPG
Просмотров: 60
Размер:	25.2 Кб
ID:	7111  
16.03.2016 13:40
aldemko
 
1:
/usr/sbin/php-fpm -version
PHP 5.6.19 (fpm-fcgi) (built: Mar 3 2016 08:05:50)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

почему он php не видит ?
только Html
16.03.2016 14:19
OlegON
 
Для php необходимо создать location, который будет отдавать его в php-fpm. Без такой передачи он будет все отдавать просто файлами, без обработки.
16.03.2016 15:15
aldemko
 
Я пробовал снять комментарии
не помогло или там не так написано


Просто когда с панели вебузо все делалось, там не надо было ничего такого указывать
а тут теперь загвоздка
(хотя я так понимаю теперь , если разобраться, можно будет более гибко настроить )
Миниатюры
Нажмите на изображение для увеличения
Название: Снимок.JPG
Просмотров: 59
Размер:	37.4 Кб
ID:	7113  
16.03.2016 15:26
OlegON
 
У тебя есть сайт nginx, примеры своих конфигов, я тут тоже выкладывал, ничто не мешает самому уже понять, что нужно туда писать.
Спрашивай что-то конкретное.
16.03.2016 15:28
aldemko
 
нашел , пробовать буду
только проблемы с редактированием текста в mc
(но это уже другая тема)
сейчас пробую разные варианты
главное что Nginx работает, и без глюков (установленный через панель то перезагружался, то не реагировал на команду рестарта)
16.03.2016 16:11
aldemko
 
Странное дело
вставляю конфиг который 100% ранее работал (я копии делал)
а он не работает
еще поищу что может быть

Хотя там может все было включено панелью
а сейчас то без панели
ищу дальше
16.03.2016 16:41
aldemko
 
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.


ошибка 404
я даже не могу открыть phpinfo что бы дальше задавать какие то вопросы основываясь на нем
html и другие файлы читает


оо зато уже php файлы не скачивает а 404
16.03.2016 16:51
OlegON
 
root правильно прописал? 404 - нет файла. либо его нет, либо нет прав на него совсем.
16.03.2016 16:59
aldemko
 
Вроде все правильно
Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.
Миниатюры
Нажмите на изображение для увеличения
Название: prava.JPG
Просмотров: 62
Размер:	18.1 Кб
ID:	7118  
16.03.2016 17:01
twix
 
А конфиг можно глянуть?
Есть мнение, что не корректно задан root.

На всякий случай, чтобы свериться, простейший конфиг для цайта:

Код:
server {
	listen 80;

	root /var/www/public_html/bezzapaha.ru;
	index index.php index.html index.htm;

	server_name bezzapaha.ru;

	location / {
		try_files $uri $uri/ =404;
	}

	location ~ \.php$ {
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
		# NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		fastcgi_index index.php;
		include fastcgi_params;
	}
}
16.03.2016 17:04
aldemko
 
/etc/nginx/conf.d/domen.conf:


Скрытый текст (вы должны войти под своим логином или зарегистрироваться и иметь 21 сообщение(ий)):
У вас нет прав чтобы видеть скрытый текст, содержащийся здесь.


пробовал и www и вот public_html
все в одну папку все равно ведет
результат тот же


Попробовал

Цитата:
twix А конфиг можно глянуть?
Есть мнение, что не корректно задан root.

На всякий случай, чтобы свериться, простейший конфиг для цайта:

Код:
server {
	listen 80;

	root /var/www/public_html/bezzapaha.ru;
	index index.php index.html index.htm;

	server_name bezzapaha.ru;

	location / {
		try_files $uri $uri/ =404;
	}

	location ~ \.php$ {
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
		# NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
		fastcgi_pass unix:/var/run/php5-fpm.sock;
		fastcgi_index index.php;
		include fastcgi_params;
	}
}
результат тот же
service nginx restart делал
16.03.2016 17:05
twix
 
root задай для сервера, а не для локейшена.

Должно быть как-то так:

Код:
server { 
    listen       80; 
    server_name bezzapaha.ru; 

    root   /home/aldemko/public_html/bezzapaha.ru;
    index index.php  index.html index.htm; 

    # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000 
    # 
    location ~ \.php$ { 
        fastcgi_pass   127.0.0.1:9000; 
        fastcgi_index  index.php; 
        fastcgi_param  SCRIPT_FILENAME   $document_root$fastcgi_script_name; 
        include        fastcgi_params; 
    } 
}
16.03.2016 17:11
aldemko
 
Цитата:
twix root задай для сервера, а не для локейшена.

Должно быть как-то так:

Код:
server { 
    listen       80; 
    server_name bezzapaha.ru; 

    root   /home/aldemko/public_html/bezzapaha.ru;
    index index.php  index.html index.htm; 

    # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000 
    # 
    location ~ \.php$ { 
        fastcgi_pass   127.0.0.1:9000; 
        fastcgi_index  index.php; 
        fastcgi_param  SCRIPT_FILENAME   $document_root$fastcgi_script_name; 
        include        fastcgi_params; 
    } 
}

502 Gateway


Может у меня проблема с php-fpm (только как проверить не зняю для nginx - service nginx status пишет что ОК
а с этим то рунинг то service php-fpm status
php-fpm: unrecognized service
)
nginx я то удалил с панели и установил заново через ком строку
а вот php-fpm не удалялся
16.03.2016 17:14
twix
 
Цитата:
aldemko 502 Gateway
Похоже, что php-fpm не слушает порт 9000.
Что говорится в ответ на
Код:
cat /etc/php5/fpm/pool.d/www.conf | grep "listen ="
* Вместо "/etc/php5/fpm/pool.d/www.conf" подставить путь к конфигу твоего php-fpm
16.03.2016 17:17
twix
 
Цитата:
aldemko а с этим то рунинг то service php-fpm status
php-fpm: unrecognized service
)
А если php5-fpm?
А если yum install php-fpm?
У тебя же, вроде, крутятся другие сайты на этой же VPS? Они с пыхом работают?
16.03.2016 17:22
aldemko
 
Крутились....
пока мне моча в голову не ударила сделать так что бы php-fpm был не php 5.3 а php 5.6
после вот весь день сижу
https://olegon.ru/showthread.php?t=24206
https://olegon.ru/showthread.php?t=23973

Код:
 service php5-fpm status
php5-fpm: unrecognized service
Код:
yum install php-fpm
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirrors.coreix.net
 * epel: epel.mirrors.ovh.net
 * extras: mirrors.coreix.net
 * remi-safe: rpms.remirepo.net
 * updates: mirrors.coreix.net
 * webtatic: uk.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package php-fpm.x86_64 0:5.3.3-46.el6_7.1 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_7.1 for package: php-fpm-5.3.3-46.el6_7.1.x86_64
--> Finished Dependency Resolution
Error: Package: php-fpm-5.3.3-46.el6_7.1.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-46.el6_7.1
           Installed: php-common-5.6.19-1.el6.remi.x86_64 (@remi-php56)
               php-common(x86-64) = 5.6.19-1.el6.remi
           Available: php-common-5.3.3-40.el6_6.x86_64 (base)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-46.el6_7.1.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_7.1
           Available: php54w-common-5.4.45-2.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.4.45-2.w6
           Available: php55w-common-5.5.32-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.5.32-1.w6
           Available: php56w-common-5.6.18-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.6.18-1.w6
           Available: php70w-common-7.0.3-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 7.0.3-1.w6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
16.03.2016 17:24
twix
 
Смотрю, подцепил левые репы. У мну тоже где-то реми был подключен. Но я с него не ставился.
Попробуй: "yum --enablerepo=remi install php-fpm"
16.03.2016 17:29
aldemko
 
Цитата:
twix Смотрю, подцепил левые репы. У мну тоже где-то реми был подключен. Но я с него не ставился.
Попробуй: "yum --enablerepo=remi install php-fpm"
ответ:
Код:
 yum --enablerepo=remi install php-fpm
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirrors.coreix.net
 * epel: ftp.nluug.nl
 * extras: mirrors.coreix.net
 * remi: rpms.remirepo.net
 * remi-safe: rpms.remirepo.net
 * updates: mirrors.coreix.net
 * webtatic: uk.repo.webtatic.com
remi                                                     | 2.9 kB     00:00
remi/primary_db                                          | 1.4 MB     00:00
Resolving Dependencies
--> Running transaction check
---> Package php-fpm.x86_64 0:5.4.45-5.el6.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.4.45-5.el6.remi for package: php-fpm-5.4.45-5.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-fpm-5.4.45-5.el6.remi.x86_64 (remi)
           Requires: php-common(x86-64) = 5.4.45-5.el6.remi
           Installed: php-common-5.6.19-1.el6.remi.x86_64 (@remi-php56)
               php-common(x86-64) = 5.6.19-1.el6.remi
           Available: php-common-5.3.3-40.el6_6.x86_64 (base)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-46.el6_7.1.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_7.1
           Available: php-common-5.4.45-4.el6.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.45-4.el6.remi
           Available: php-common-5.4.45-5.el6.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.45-5.el6.remi
           Available: php54w-common-5.4.45-2.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.4.45-2.w6
           Available: php55w-common-5.5.32-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.5.32-1.w6
           Available: php56w-common-5.6.18-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 5.6.18-1.w6
           Available: php70w-common-7.0.3-1.w6.x86_64 (webtatic)
               php-common(x86-64) = 7.0.3-1.w6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Опции темы


Часовой пояс GMT +3, время: 21:09.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.