Форум OlegON > Компьютеры и Программное обеспечение > Сеть

Как заблокировать клиента по времени : Сеть

17.05.2022 20:12


Контакты Поиск
21.10.2016 14:29
OlegON
 
Возникла необходимость отключать пару устройств по времени, пока не пробовал, но соорудил конструкцию
Код:
/system scheduler
add interval=1d name="Off morning" on-event="/ip dhcp-server lease\
    \nset [ find address=192.168.10.30 ] block-access=yes\
    \nset [ find address=192.168.10.33 ] block-access=yes\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=oct/21/2016 \
    start-time=11:00:00
add interval=1d name="Off evening" on-event="/ip dhcp-server lease\
    \nset [ find address=192.168.10.30 ] block-access=yes\
    \nset [ find address=192.168.10.33 ] block-access=yes\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=oct/21/2016 \
    start-time=21:30:00
add interval=1d name="On morning" on-event="/ip dhcp-server lease\
    \nset [ find address=192.168.10.30 ] block-access=no\
    \nset [ find address=192.168.10.33 ] block-access=no\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=oct/21/2016 \
    start-time=07:00:00
add interval=1d name="On evening" on-event="/ip dhcp-server lease\
    \nset [ find address=192.168.10.30 ] block-access=no\
    \nset [ find address=192.168.10.33 ] block-access=no\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=oct/21/2016 \
    start-time=20:30:00
При том, что lease 10 минут, есть предположение, что клиент отвалится и получит левый IP. Ничто, конечно, не мешает прибить фиксированный IP, но для этого нужны определенно другие умения на стороне клиента, чем имеются сейчас :)
01.11.2016 14:38
Dmitrya
 
Можно это реализовать несколько другими способами.

#закрытие доступу к интернету для некоторых MAC адресов
/ip firewall filter add chain=forward action=jump jump-target=RestrictedTime

/ip firewall filter add chain=RestrictedTime src-mac-address="00155dec0401" action=drop disabled=yes comment="block mac" time=11:00:00-20:30:00,mon,thu,wed
/ip firewall filter add chain=RestrictedTime src-mac-address="00155dec0401"action=accept disabled=yes comment="block mac"
/ip firewall filter add chain=RestrictedTime action=return


Таким образом можно добиться блокировке устройств по маку, времени,дню недели.
01.11.2016 16:02
OlegON
 
Проблема в том, что кустистые правила стенки (firewall) обрабатываются процессором, т.е. помимо того, что греют и нагружают Mikrotik, так еще и тормозят проход пакетов... Я стараюсь стенкой пользоваться в крайнем случае...

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.