Форум OlegON > Компьютеры и Программное обеспечение > Сеть

Есть ли в Mikrotik нормальный cron?

06.04.2020 7:12


28.10.2016 07:39
OlegON
 
Собственно, налетел на неприятную особенность. Есть Scheduler, есть Netwatch, однако нельзя назначать задания, например, по дням недели или в определенное время суток. Если только извращаться со скриптами, запускаемыми, например, раз в минуту?
01.11.2016 13:01
Dmitrya
 
Как такового решения аналогичного crontab там нет, но интервал запуска и начальное время запуска - скрипта, события, действия можно добиться используя значения.

Пример: Надо нам запускать какое-то действие раз в 2 дня, в 1 час ночи.
пишем на Cli или просто делаем в планировщике задание

/system scheduler add name=test start-time=01:00:00 interval=2d

Раз в 30 минут

/system scheduler add name=test start-time=01:00:00 interval=00:30:00

Таким образом можно делать какие либо действия в определенное время суток, раз в неделю итд.
К сожалению по дням недели пока без извращений выполнение каких-либо задач не получается.
01.11.2016 16:18
OlegON
 
Благодарю, на самом деле я и сам уже добрался до этой неприятности. Кстати, в Wiki Mikrotik (в разделе примеров или юзерских скриптов) есть скрипт вычисления дня недели. Нехилый такой скриптик, скажем :)

Пока нерешаемых задач не возникает, поскольку, действительно, много где есть указание времени, в том числе и дня недели, есть тот же Netwatch...

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.