[ОТВЕТИТЬ]
Опции темы
28.10.2016 20:32  
root221
Добрый вечер,

Необходима помощь в решении вопроса,

У нас в магазине стоит связка fprint-03k & arcus2 & 1C,

суть вопроса в следующем, когда мы начинаем печатать чек по эквайрингу (Безнал), то в обработке обслуживания АРКОМ есть в функциях строка, КоличествоКопий = 2;, так вот при печати чека распечатываются сразу две копии чека, что нужно сделать что-бы между ними была некая задержка секунд 10 что-бы продавцы успевали оторвать первый чек, а затем уже второй.

Очень рассчитываю на вашу подсказку .
 
28.10.2016 20:34  
root221
Да, забыл...

Терминал эквайринга IPP320 от ВТБ.
 
28.10.2016 23:04  
baggio
а не пробовали резать между слипами?
фискальники умеют отрезать чек ... да..
 
29.10.2016 01:59  
root221
Baggio,

Простите, не совсем вас до конца понял, вы имеете ввиду на фискальнике fprint 03k есть такая настройка?

Если я правильно вас понял то Вы имели ввиду что можно останавливать печать на короткое время когда до печатался низ чека ккм ?, а затем после паузы он может продолжить печатать уже вторую копию ?, если так, то тогда как эту паузу можно настроить, вы можете подсказать ?
 
30.10.2016 17:44  
baggio
я имел ввиду что ККМ он же ФР отрезает чек автоматически(если конечно настроено) после того как допечатал документ...
так вот ваша настройка "КоличествоКопий = 2" должна посылать в ФР документ два раза, а не один документ с количеством копий 2...
мучайте одынэсников чтобы они посылали в ФР слип два паза и каждый изх них будет отрезаться..
 
30.10.2016 20:07  
root221
Функцию отрезки чеков наш ФР не поддерживает, поэтому необходима пауза, что бы сотрудники успевали оторвать чек.

Вот как эту паузу сделать, пока для меня остаётся загадкой.

мучайте одынэсников чтобы они посылали в ФР слип два паза и каждый изх них будет отрезаться.. - Нету у нас один 1сников =(( сами ковыляем.
 
31.10.2016 08:17  
Shift
Быть может, поставить количество копий=1, затем пустой цикл, а затем ещё копию?
 
31.10.2016 10:18  
baggio
Бинго! Просто печатать один и тот же документ 2 раза...
А не один документ с количеством копий 2
 
02.11.2016 19:58  
root221
Если можете, скажите как написать цикл

вот код

Цитата:

// Функция осуществляет авторизацию (оплату) по карте.
// (API v2.0)
//
// Параметры:
// Объект - <*>
// - Объект драйвера ЭС.
//
// Сумма – <Число>
// - Сумма к оплате по карте
//
// КодRRN - <Строка>
// - Уникальный код RRN транзакции
//
// КодАвторизации - <Строка>
// - Возвращается код авторизации транзакции
//
// КодОперации - <Строка>
// - Последовательный код операции
//
// МассивСтрокСлипЧека - <Структура>
// - Массив строк слип-чека, сформированного
// после успешного выполнения операции
//
// ШиринаЧека - <Число>
// - Ширина слип-чека, установленная в параметрах настройки
//
// КоличествоКопий - <Число>
// - Количество печатаемых копий слип-чека
//
// Возвращаемое значение:
// <ПеречислениеСсылка.ОшибкиПриРаботеСТорговымОборудованием>
// - Результат работы функции.
//
Функция ОплатитьПлатежнойКартой(Объект, Сумма, КодRRN, КодАвторизации, КодОперации, МассивСтрокСлипЧека, ШиринаЧека, КоличествоКопий) Экспорт

мТипТранзакции = "Оплата";
мНомерКарты = "";
мКодRRN = "";
мКодАвторизации = "";
КоличествоКопий = 2;
КаталогОбменаЭКВ = Объект.Параметры.КаталогОбмена;
НомерКоманды = 1;
КодRRN = "";
КодАвторизации = "";
Объект.ОписаниеОшибки = "Команда успешно выполнена.";
ШиринаЧека = Объект.Параметры.ШиринаСлипЧека;

Если Объект.Параметры.Свойство("КодВалюты") Тогда
КодВалюты = Число(Объект.Параметры.КодВалюты);
Иначе
КодВалюты = 810;
КонецЕсли;

Рез = ВыполнитьКомандуАРКОМ(НомерКоманды, Сумма, Объект.ОписаниеОшибки, КаталогОбменаЭКВ, 1,МассивСтрокСлипЧека,КодВалюты);

Если Рез = 1 Тогда
Результат = мНетОшибки;
Иначе
Результат = мОшибкаНеизвестно;
КонецЕсли;

Возврат Результат;

КонецФункции

 
03.11.2016 08:04  
Shift
покажите текст ВыполнитьКомандуАРКОМ
 
 


Опции темы



Часовой пояс GMT +3, время: 16:39.

Все в прочитанное - Календарь - RSS - - Карта - Вверх

Форум сделан на основе vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.