Форум OlegON > Компьютеры и Программное обеспечение > Сеть

Mikrotik. Автогенерация пароля для гостевой сети Wi-Fi

02.04.2020 23:18


20.11.2016 13:05
OlegON
 
В связи с тем, что Windows 10 сливает пароли, а так же для того, чтобы пускать доверенных людей, которые не умеют контролировать свои устройства, создал еще одну виртуальную сеть Wi-Fi, в которой, по расписанию меняю пароли каждый день. Вот заготовка скрипта для этих целей

Код:
{
:local date [/system clock get date]
:local months [:toarray "jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"]
:local month [:pick $date 0 3]
:local day [:pick $date 4 6]
:local dayc [:pick $date 5 6]
# if the first char is a 0 (zero) only read last char, else script fails
:if ([:pick $date 4 5] = 0) do={ :set day ($dayc)}
:local nmonth 1
:for mindex from=0 to=[:len $months] do={
  :if ([:pick $months $mindex] = $month) do={:set nmonth ($mindex + 1) }
}
:set $nmonth (5555-($nmonth*100+$day))
/interface wireless security-profiles
set [find name="guest"] wpa2-pre-shared-key="!$nmonth$nmonth+"
}
Собственно, берем дату в формате ММДД, вычитаем это число из 5555, полученное число повторяем два раза и окружаем символами ! и +... Получается не бронебойное, но куда лучше, чем если слить основной и неизменяемый пароль.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.