Форум по программам и оборудованию > >

Mikrotik. Очередь блокирует траффик полностью.

21.10.2019 18:34


06.07.2017 13:36
OlegON
 
Прошу надоумить, какая-то ерунда.
Дано:
локалка-Mikrotik-хост-инет
Задача: из локалки ограничить траф в инет, но не ограничивать к хосту. На хосте NAT.

Но это пока не в тему. Тема в другом. Траф по SSH льется со скоростью 80Мб/сек. Делаю.
Код:
/queue type
add kind=pfifo name=default-big pfifo-limit=100
/queue simple
add name=box priority=1/1 queue=default-big/default-big target=адрес хоста
т.е. простейшая очередь без ограничений, после чего траф падает до жутких цифр
Цитата:
76,742,656 6% 20.37kB/s 1:28:54
вырубаю нафик очередь - разгоняется до прежних значений. Это вообще что? :( Если обычно при переполнении очереди ее значок краснеет, то тут ничего такого нет.
06.07.2017 13:40
baggio
 
посмотри загрузку проца микротика...
06.07.2017 13:47
OlegON
 
Да, забыл написать, 1%
Собственно, я уже все очереди и правила Firewall снес, в попытках понять, что происходит. Там нечему тормозить.
Да, все остальное шуршит неплохо. Именно на этот хост проблемно идет...
06.07.2017 13:57
OlegON
 
Собственно, поставил default в тип... 4.99kB/s
Ниччего не понимаю...
06.07.2017 14:27
OlegON
 
Судя по iperf, в сторону хоста при включенной очереди - 1МБит, обратно - 600МБит. При выключенной очедеди, в сторону хоста - 700Мб.
Есть подозрения, что это MTU гадит. Но его сбросить нельзя :( Ребут не помогает. Может, есть у кого-то еще идеи, кроме как все вообще сбросить? :(
09.07.2017 13:04
OlegON
 
Полный сброс ничего не дал...
28.07.2017 14:49
OlegON
 
Если у кого-то будут идеи по вопросу - обязательно отпишитесь. У меня сейчас пока никаких идей не осталось. Типы очередей менял, ошибок на интерфейсе нет, вокруг все летает, а именно копирование по SSH, именно на этот хост, через который весь траф идет без проблем, падает скоростью до нуля. Если надо что-то скопировать - приходится останавливать очереди и вручную проталкивать.
30.07.2017 09:48
OlegON
 
В общем, уперся, сел смотреть.

Да, проц. Что интересно, пока не ребутнул рутер, этого не видел. Ну да, колупалась нагрузка до 40%, а все лежит... Перезагрузил, проц сразу лег на 100%. По ~ 30% на networking, на queueing и на firewall.

Итоги. Больше 80Мб/сек не рутит даже вообще без правил. С одной simple queue на интерфейс скорость падает до 30Мб/сек, правда, с двумя всего до 25Мб/сек падает. Если попытаться включить маркировку пакетов в prerouting по протоколу и порту - отжирает четверть ресурсов и вместе с очередью начинаются свистопляски :( Плюс, конечно, в том, что остальное работает. Однако, тот поток, который клал процессор, умирает вообще.
05.10.2017 09:03
OlegON
 
Кстати, история закончилась. Переделал все, была пара бриджей, собственно, я в бридж все интерфейсы объединил, а не мастер-портом. Впрочем, если через мастер-порт объединять, интерфейсы все равно в бридж собираются. Только не тормозят. Объединил портом, выкинув из бриджа - нагрузка существенно упала. Вроде даже до 90Мб уже с правилом позволяет пропускать. Но однозначно не на такие скорости железка, увы.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.