25.07.2018 10:13
obltorg
 
Добрый день.
Обновляю Set10 с 10.2.31.1_10.2.31.2. В логах выдаёт ошибку:

25.07.2018 10:02:13
Current status is APPLY_PATCH
Current patches list is [centrum_10.2.31.1_10.2.31.2]
ERROR MESSAGE:
ru.crystals.cm.UpdateException: Error process WIN command ([C:\Program Files (x86)\PostgreSQL\8.4\bin\psql, -h, localhost, -p, 5432, -U, postgres, -d, set, -v, ON_ERROR_STOP=1, -f, C:\Program Files (x86)\SetRetail10\acm\updates\unzip_centrum_10.2.31.1_10.2.31.2\restore\set_U_10.2.31.2_101.sql]):
CREATE TABLE
ALTER TABLE
COMMENT
COMMENT
COMMENT
COMMENT
COMMENT
CREATE SEQUENCE
CREATE FUNCTION
ERROR:
psql:C:/Program Files (x86)/SetRetail10/acm/updates/unzip_centrum_10.2.31.1_10.2.31.2/restore/set_U_10.2.31.2_101.sql:14: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "erpi_export_table_queue_pkey" for table "erpi_export_table_queue"
psql:C:/Program Files (x86)/SetRetail10/acm/updates/unzip_centrum_10.2.31.1_10.2.31.2/restore/set_U_10.2.31.2_101.sql:45: ERROR: syntax error at or near "WHEN"
?????? 3:AFTER UPDATE ON erp FOR EACH ROW WHEN (NEW.registered <> OLD...
^

at ru.crystals.cm.utils.NativeHelper.processCommandWithOutput(NativeHelper.java:381)
at ru.crystals.cm.utils.NativeHelper.processCommandWithOutput(NativeHelper.java:317)
at ru.crystals.cm.utils.SQLHelper.execScript(SQLHelper.java:131)
at ru.crystals.cm.utils.SQLHelper.execScript(SQLHelper.java:122)
at ru.crystals.cm.AbstractConfigurationUpdater.applySQL(AbstractConfigurationUpdater.java:617)
at ru.crystals.cm.AbstractConfigurationUpdater.applySQLFromPath(AbstractConfigurationUpdater.java:612)
at ru.crystals.cm.AbstractConfigurationUpdater.applyPatch(AbstractConfigurationUpdater.java:418)
at ru.crystals.cm.AbstractConfigurationUpdater.doUpdate(AbstractConfigurationUpdater.java:256)
at ru.crystals.cm.AbstractConfigurationUpdater.start(AbstractConfigurationUpdater.java:88)
at ru.crystals.cm.server.ServerUpdater.main(ServerUpdater.java:93)

В чём может быть проблема. Спасибо
25.07.2018 15:01
nik_ll
 
Пробовали удалить патч и скачать заново?
25.07.2018 16:45
obltorg
 
пробовал.
Может у кого он есть, я бы попробовал из др. источника)
26.07.2018 14:12
vitamin
 
через pg_admin прогнать скрипт, в сообщениях будет видно ошибку

:upd
Цитата:
([C:\Program Files (x86)\PostgreSQL\8.4\bin\
Cначала обновите postgres до 9.4 и в переменных системы заменить на новый путь к bin.
Еще в 2017 году кристал писал об этом на сайте...
Инструкция по обновлению.
Затем штатно обновить.
02.08.2018 11:26
obltorg
 
Вопрос решился закачкой исправленного патча, без обновления postgre
03.08.2018 08:32
nik_ll
 
На 9.4 все же надо перейти. С 40-какойто версии только на 9 работает
03.08.2018 09:22
obltorg
 
Это да, я видел
03.08.2018 10:40
asfw7qlm2
 
Цитата:
nik_ll На 9.4 все же надо перейти. С 40-какойто версии только на 9 работает
У них на сайте написано:
Начиная с версии 10.2.45.0, прекращается поддержка PostgreSQL 8.4 и SetRetail10 полностью переходит на PostgreSQL 9.4.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.