Форум по программам и оборудованию > >

Mikrotik. Скрипт смены пароля на гостевой сети.

19.09.2018 14:17


11.09.2018 13:15
OlegON
 
Понадобилось сделать на гостевой Wi-Fi сети ежедневную смену пароля и так, чтобы уж не совсем очевидно было, как он генерируется.

Код:
:local date [/system clock get date]
:local months [:toarray "jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"]
:local month [:pick $date 0 3]
:local day [:pick $date 4 6]
:local dayc [:pick $date 5 6]
:if ([:pick $date 4 5] = 0) do={ :set day ($dayc)}
:local nmonth 1
:for mindex from=0 to=[:len $months] do={
  :if ([:pick $months $mindex] = $month) do={:set nmonth ($mindex + 1) }
}
:set $nmonth (7777-($nmonth*100+$day))
/interface wireless security-profiles
set [find name="guest"] wpa2-pre-shared-key="+$nmonth$nmonth!"
Странно, казалось, что выкладывал...

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.