Форум OlegON > Программы и оборудование для автоматизации торговли > Маркировка

Как программно подписать данные УКЭП : Маркировка

18.04.2024 16:35


26.01.2024 10:06
FinSoft
 
Цитата:
victuan Можно 64-разрядную.
А для 32 разрядных приложений дополнительно устанавливать 32 разрядную версию CADESCOM? Иначе оно работать не будет.
26.01.2024 10:30
student
 
Цитата:
FinSoft Вроде наоборот, кадеском вместе с дистрибутивом Крипто-Про идет, а капиком надо ставить...
сложно сказать - детально не разбирался, но капиком в программах использовал без отдельной установки еще до установки криптопро с кадескомом :)
26.01.2024 10:35
FinSoft
 
Цитата:
student сложно сказать - детально не разбирался, но капиком в программах использовал без отдельной установки еще до установки криптопро с кадескомом :)
У тебя вроде тоже 32 разрядное приложение. Ставите крипто-про 32 разряда или крипто-про 64 разряда плюс cadescom 32 разряда? Я вчера на грабли с разрядностью наступил, целый день убил, пока понял в чем дело.
26.01.2024 10:47
student
 
Цитата:
FinSoft У тебя вроде тоже 32 разрядное приложение. Ставите крипто-про 32
да все именно так :) по моему странно для 32 разрядных приложений использовать 64 разрядные компоненты как в общем то и наоборот
26.01.2024 12:05
FinSoft
 
Цитата:
student да все именно так :) по моему странно для 32 разрядных приложений использовать 64 разрядные компоненты как в общем то и наоборот
А где берете дистрибутив для 32 разрядов? Меня айтишник уверяет, что есть единый и ставится с той разрядностью, какая винда.
26.01.2024 12:11
FinSoft
 
Ладно, занимаются люди этим вопросом...
26.01.2024 12:43
student
 
Цитата:
FinSoft А где берете дистрибутив для 32 разрядов
я писал выше - отдельно ничего не ставили - все родное что было в винде, возможно вместе сдк прилетел х\з
а так есть CAPICOM-KB931906-v2102 я так понимаю основной дистриб и есть отдельный архив с длл и инф файлом - по моему со сбера как то прилетал, там
Код:
;
;DestDir can be 10 for Windows directory, 11 for Windows\System(32) directory.

[version]
; version signature (same for both NT and Win95) do not remove
signature="$CHICAGO$"
AdvancedINF=2.0

[SourceDisksNames]
; This section specifies that all sources are in the "default" location.
1="default",,1

[DefaultInstall]
; Default section to process and copy all files under the section
; capicom.files and Register DLLs under the section capicom.register.
CopyFiles=capicom.files
RegisterOCXs=capicom.register

[DestinationDirs]
; Destination Directories for CopyFiles Sections.
; 11 indicates LDID_SYS - system directory
capicom.files=11

[capicom.files]
; ,,,32 - Suppress version conflict dialog and don't overwrite newer DLLs
capicom.dll,,,32

[capicom.register]
%11%\capicom.dll
хотя сейчас посмотрел свойства длл - там нет ничего про 64

Правка: student, 26.01.2024 12:54
29.01.2024 22:37
FinSoft
 
Такой вопрос, к данной теме не совсем относится, но новую создавать смысла нет.
После успешной отправки по api документа постановки кеги на кран возвращается идентификатор этого документа. По идее, должно быть можно запросить статус документа по этому идентификатору. Но в документации про это ничего не сказано. Речь именно про постановку кеги на кран, не про статус упд и т.п. Или я устал уже... Кто-нибудь решает этот вопрос?
29.01.2024 22:54
MWWRuza
 
А чем этот документ отличается от любого другого?
У меня так работает:

Процедура ПроверитьСтатус()
Url = АдресСервераМОТП + "/" + ПрефиксВерсии + "/doc/" + СокрЛП(УинДокаЦРПТ) + "/info";
Если ПроверитьПолучитьТокен() = 0 Тогда
Предупреждение("Отсутствует токен авторизации. Проверьте доступ к интернету и доступность ЭЦП!");
КонецЕсли;
сзЗаголовки = СоздатьОбъект("СписокЗначений");
сзЗаголовки.ДобавитьЗначение("no-cache", "cache-control");
сзЗаголовки.ДобавитьЗначение("*/*", "Accept");
СтрОшибка = "";
Рез = глHTPP_ВыполнитьЗапрос("GET", Url, , ТекТокен, сзЗаголовки, СтрОшибка);
СзОтвета = глРазборJSON(Рез);
СтарСтат = СокрЛП(Статус);
Статус = СзОтвета.Получить("status");
Если СтарСтат <> СокрЛП(Статус) Тогда
Записать();
КонецЕсли;
ДоступностьКонтролов();
КонецПроцедуры
29.01.2024 23:22
FinSoft
 
Спасибо, увидел, это пункт 6.3 в документации. Завтра попробую, пока связь с удаленным компом пропала.
Часовой пояс GMT +3, время: 16:35.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.