12.09.2021 11:38
sergmuz
 
Всем привет !

Бьюсь уже второй день в попытках заставить б/у весовую ячейку Datalogic magellan 8400 передавать данные на ком-порт, пока безрезультатно.

Делал все, что можно по инструкциям скачанных с интернета, переводил режим single cable и в режим работы по двум кабелям все глухо.

Scale = enable делал.

Как проверяю:

Запускаю терминал Putty со сканом портов COM1 и COM3 (скорость на обеих 9600) к которым подключены интерфейсы весов POS TERMINAL и SCALE HOST

С POS TERMINAL приходит штрих-код в Putty, со сканером все ок, с весовой ячейки ничего не приходит ни на один порт, ни в режиме single cable ни standart.

С этими весами ранее не работал, помогите пож-та, конечная цель - передача данных скана и весов по двум интерфейсам.

Спасибо !
13.09.2021 12:02
asfw7qlm2
 
В сканер 8400 могут встраиваться различные весы, какие именно у вас там встроены?
13.09.2021 13:02
sergmuz
 
Цитата:
asfw7qlm2 В сканер 8400 могут встраиваться различные весы, какие именно у вас там встроены?
если честно не знаю как посмотреть модель весов.


результат тестирования утилитой PortToolkit 4.0 производилось в режиме одного порта INTERFACE TYPE= RS-232 SINGLE CABLE командой запроса веса: 53 31 31 0d 0d дает ответ от весов


Для работы в нашей программе нужен режим работы по раздельным портам INTERFACE TYPE= RS-232 STANDART

В режиме INTERFACE TYPE= RS-232 STANDART сканер передает данные с Terminal Port->COM1

ответа от весов на порту Scale HOST->COM3 в программе не получаем, хотя разработчик утверждает, что запрос на весы отправляется.

Форум на базе vBulletin®
Copyright © Jelsoft Enterprises Ltd.
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.