[ОТВЕТИТЬ]
Опции темы
12.06.2008 11:46  
Ainur_T
ПО (Oracle 9i ,ORA_SM2000, c:\oracle\ora2000)
Добрый день!
У меня следующие вопросы.
1. Установил MSi, NetFramework, MDAT2.7, VC 8.0 DLL (бязательное для ХР тоже). после установил оракл ипатчи к нему? всё по документации. Пытаюсь установить Pracle repots выходит ошибка (миниатюра 1).
2. При установке оракла возникла следующая ошибка (устанавливал с винта, миниатюра 2), попробывал установить с диска ошибка не было, установка прошла нормально. Почему так произошло.
3. При установке MDAC 2.8 произошла ошибка (миниатюра 3), потом попробывал установить MDAC 2.7, всё установилось нормально. В чем проблема может это зависит от компа.
4. В документации написано что
ЪЕсли один и тот же компьютер будет использоваться и в качестве сервера базы данных и в качестве рабочего места оператора, то на этом компьютере должен быть установлен «Oracle 8.0 (Release8.0.6) Client» и «Oracle Report Runtime 8.0» , а также «Oracle Server 8.1.6». Установка должна быть сделана строго в указанном порядке: сначала станавливается «Oracle Client 8.0», а затем «Oracle Server 8.1.6».Ъ
вопрос в следующем как я понимаю «Oracle Client» устанавливается из дистрибутива Oracla (выбирается в Available Products ставиться точка в Oracle9i Client 9.2.0.1.0), а где находится «Oracle Server»? Ведь когда мной устанавливался Oracle выбиралась галочка Oracle9i DatBase 9.2.0.1.0
Миниатюры
Нажмите на изображение для увеличения
Название: Oracle reports.JPG
Просмотров: 419
Размер:	13.7 Кб
ID:	266   Нажмите на изображение для увеличения
Название: Ошибка при установке оракла.JPG
Просмотров: 429
Размер:	10.8 Кб
ID:	267   Нажмите на изображение для увеличения
Название: Oibmrf при установке MDAC 2.8.JPG
Просмотров: 437
Размер:	8.8 Кб
ID:	268  
 
12.06.2008 12:27  
baggio
1.первая ошибка говорит о том что каталог в который ты хочешь поставить репортсы занят другим oracle - выбери другой(любой).
2. ошибка скорее всего свидетельствует о том что у тебя дистриб либо битый либо порезанный... на каком компоненте выскакивает данная ошибка?
3. Ошибка говорит о том что твойц MDAC 2.8 не поддерживает установку на твою операционную систему... возможно он под 2003 а ты ставишь на ХР или наоборот. на кокую ос ставишь?
 
16.06.2008 07:50  
akonev
Цитата:
Сообщение от Ainur_T
вопрос в следующем как я понимаю «Oracle Client» устанавливается из дистрибутива Oracla (выбирается в Available Products ставиться точка в Oracle9i Client 9.2.0.1.0), а где находится «Oracle Server»? Ведь когда мной устанавливался Oracle выбиралась галочка Oracle9i DatBase 9.2.0.1.0
Имеется в виду установка именно клиента 8.0.6!!! Из отдельного дистрибутива.
Он ставится в точности по инструкции. То есть из него нужны только перечисленные пять пунктов. Можно только еще Report Builder добавить, если предполагаешь рисовать отчеты/ценники.
Потом отдельно ставишь серверную девятку.

То же самое для клиетских машин: ставится клиент 8.0.6

Только имей в виду, что ставить на одну машину клиента и сервер имеет смысл в одном из трех случаев:
1) это учебный сервер
2) это демо-машина
3) ты опытный админ и знаешь, что и для чего ты делаешь
для остальных случаев, включая рабочие базы и резервные серверы, клиента лучше не ставить

Все библиотеки, которые ты перечислил, можно ставить после оракла, но обязательно перед установкой супермага.
Для начала так будет даже лучше: сначала победить оракл, получить работающую пустую базу.
Просто есть большая вероятность, что систему все равно придется переставлять после неудачных экспериментов с ораклом.
 
30.06.2008 21:43  
Ainur_T
Цитата:
Сообщение от Andrew_Konev
Имеется в виду установка именно клиента 8.0.6!!! Из отдельного дистрибутива.
Он ставится в точности по инструкции. То есть из него нужны только перечисленные пять пунктов. Можно только еще Report Builder добавить, если предполагаешь рисовать отчеты/ценники.
Потом отдельно ставишь серверную девятку.

То же самое для клиетских машин: ставится клиент 8.0.6

Только имей в виду, что ставить на одну машину клиента и сервер имеет смысл в одном из трех случаев:
1) это учебный сервер
2) это демо-машина
3) ты опытный админ и знаешь, что и для чего ты делаешь
для остальных случаев, включая рабочие базы и резервные серверы, клиента лучше не ставить

Все библиотеки, которые ты перечислил, можно ставить после оракла, но обязательно перед установкой супермага.

Для начала так будет даже лучше: сначала победить оракл, получить работающую пустую базу.
Просто есть большая вероятность, что систему все равно придется переставлять после неудачных экспериментов с ораклом.
Понятно, а где взять этот дистрибутив это случайно не Oracle8_server который находится на фтпшнике сервис плюса (в папке ORACLE/ORA/)
 
01.07.2008 08:14  
akonev
Цитата:
Сообщение от Ainur_T
Понятно, а где взять этот дистрибутив это случайно не Oracle8_server который находится на фтпшнике сервис плюса (в папке ORACLE/ORA/)
ORACLE/Oracle-reports
 
01.07.2008 08:52  
Ainur_T
Цитата:
Сообщение от Andrew_Konev
ORACLE/Oracle-reports
Ага есть такое, начал устанавливать там выходит сообщения (приложено) так понимаю что нужно выбирать Oracle Reports Server
Миниатюры
Нажмите на изображение для увеличения
Название: Oracle8i-reports.JPG
Просмотров: 372
Размер:	14.8 Кб
ID:	274  
 
01.07.2008 10:05  
akonev
блин!!! хотел ругнуться: RTFM, а оказалось, что с 1.026 этот раздел документации испортили. :(

Oracle Reports Developer

потом тянем из sm2000\DOK SM2000 руководство сисадмина от 1.025.1 и смотрим там в пункте 2.1.2 список из пяти компонент, которые надо поставить.
 
02.07.2008 10:41  
Ainur_T
Всё закачал:
Вобщем чтобы поставить супермаг2000
мне нужно установить
1. oracle 9.2.0.1
2. Oracle8i-reports. В котором нужно выбрать Oracle Reports Developer (в котором нужновы брать 5 пуснктов которые указанные в руководство сисадмина от 1.025.1 в пункте 2.1.2).
3. После этого установить всё из папки DotNet for 1.024.4
4. После этого установить сам супермаг по инструкции
Правильно?

вопрос в какой момент запускать файлы из папки dcoms (по текстовику я понял что послу установки супер мага)?
 
02.07.2008 12:04  
akonev
1. Oracle8i-reports...
2. oracle 9.2.0.1, далее
- патч до 9.2.0.7 или выше
- поднять листенер
- сгенерить пустую базу оракл (про установку 9-ки, до этого места включительно, есть отдельная инструкция в ORACLE\ORACLE_DOC на ftp)

Дальше правильно.

dcoms - после установки супермага, но перед настройкой его сервисов (включая "сервер супермага") - иначе просто оснастки сервисов работать не будут.
 
21.07.2008 07:50  
Ainur_T
Доюрый день.
Оракл репортс и оракл поставил усе номально. лицензер и базу сделал.
Но при инициализации базы вылазит следующее
*ORA-28009: connection to sys should be as sysdba or sysoper
*SP2-0306: Неверная опция.
*Синтаксис: CONN[ECT] [регистрация] [AS {SYSDBA|SYSOPER}]
*где <регистрация> ::= <username>[/<password>][@<connect_string>] | /
*ERROR:
*ORA-01017: неверно имя пользователя/пароль; вход в систему *запрещается
*SP2-0157: После 3 попыток соединение с ORACLE невозможно, выхожу *из SQL*Plus
хотя при создании базы указывал пороль qqq
 
 


Опции темы



Часовой пояс GMT +3, время: 23:09.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.