[ОТВЕТИТЬ]
Опции темы
02.03.2009 14:33  
Wolverine
как связать 1С 7.7 и MySQL??? Суть проблемы в следующем: написан запрос для выдергивания сторно, можно ли связать 1С 7.7 и MySQL??? чтобы написать обработку в 1с-ке и не париться с запросами sql?
 
02.03.2009 16:33  
OlegON
А 1Ске не все равно, какой источник а ADO?
Цитата:
//*******************************************
Процедура ЗаполнитьТаблицу()
MySQL_Таблица.Очистить();
MySQL_Таблица.НоваяКолонка("Id");
MySQL_Таблица.НоваяКолонка("Name");
MySQL_Таблица.НоваяКолонка("Family");
Соединение = CreateObject("ADODB.Connection");
Соединение_param = "dsn=1c;server=localhost;uid=root;database=1c_base;port=3306";
Соединение.open(Соединение_param);
РекордСет = СоздатьОбъект("ADODB.Recordset");
РекордСет.ActiveConnection = Соединение;
РекордСет.Open("select * from users");
Пока РекордСет.EOF = 0 Цикл
MySQL_Таблица.НоваяСтрока();
MySQL_Таблица.Id = РекордСет.Fields("id").Value;
MySQL_Таблица.Name = РекордСет.Fields("name").Value;
MySQL_Таблица.Family = РекордСет.Fields("family").Value;
РекордСет.MoveNext();
КонецЦикла;
РекордСет.close();
Соединение.close();
КонецПроцедуры

Процедура Выполнить()
ЗаполнитьТаблицу();
КонецПроцедуры

//*******************************************
 
03.03.2009 10:21  
Wolverine
а за что отвечает dsn?
 
03.03.2009 11:58  
OlegON
Создается системный DSN (Data Source Name, в Control Panel ищется) с именем «1c», который указывает на базу данных MySQL
 
 
Опции темы



Часовой пояс GMT +3, время: 05:58.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.