[ОТВЕТИТЬ]
Опции темы
08.07.2009 12:36  
OlegON
Цитата:
В связи с тем, что программное обеспечение, которое ранее устанавливалась на клиентские рабочие места (ORACLE 6i), стало не способно брать на себя функцию программы доступа к данным серверной части, то основным условием будет установка на каждое рабочее место - клиентской части ORACLE 8.1.7 или выше.
Жесть какая-то. Может, кому-то не сильно влом привести сюда пример "неспособности"? Что будет, если 8.1.7 не ставить?
 
08.07.2009 12:46  
Mtirt
Супермаг не запустится.
Сообщение выходит при запуске :)
 
08.07.2009 15:06  
OlegON
Такое же, как в почтовике? Просто сдается мне, что это просто прихоть компонента. И нежелание программеров с этим разобраться. Супермаг работает с базой на таком уровне, что ему такая версионность по барабану должна быть, ИМХО.
 
08.07.2009 15:08  
Mtirt
Такое же, как в почтовике.

У меня есть ответ тех.поддержки, что в связи с изменением интерфейса (закладочки, давно обсуждаемые) используется Net Framework 3.0-3.5 и это он не может взаимодействовать с клиентом оракла ниже 8.1.7.
 
08.07.2009 15:26  
OlegON
В переводе "в связи с тем, что нам влом было разбираться, вы, господа админы, теперь упретесь рогом везде все переставлять и делать из компов помойку". Кому нужны были эти закладочки...
 
08.07.2009 15:27  
Mtirt
Угу. Я вот как раз с утра ломаю голову, как обновить клиента 300 компах.
И сколько времени я буду это делать.
 
08.07.2009 15:33  
OlegON
думаю, что psexec в руки, а у оракла есть silent install, когда ты заранее подкладываешь файл ответов.
 
08.07.2009 15:44  
OlegON
Цитата:
Сообщение от sql.ru
Зачастую у пользователей в первый раз создающих приложения на основе
Microsoft.NET (версии 1, 1.1, 2.0) возникают проблемы при открытии соединения с БД.
В частности эти проблемы могут порождать ошибки наподобие "System.Data.OracleClient requires Oracle client software version 8.1.7 or greater." или "System.Data.OleDb.OleDbException: No error information available: REGDB_E_CLASSNOTREG(0x80040154)"
Для решения данной проблемы необходимо установить патч (Oracle provider for .NET), который можно скачать с официального сайта Oracle (ODP.NET)
ась? может, поможет?
 
08.07.2009 16:26  
Mtirt
Думаю, что нет.
Речь идет о .NET 3-ей версии, а в данных компонентах речь о 2-ой.
 
09.07.2009 09:42  
ReDHawK
Возможно оно и прокатило бы, но его же тоже ставить нужно *22
 
 


Опции темы



Часовой пояс GMT +3, время: 15:35.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.