[ТЕМА ЗАКРЫТА]
Опции темы
07.08.2009 18:46  
twix
доброго времени суток, %username%

прошу помочь с решением моей проблемы.
а заключается она в том, что моей сьюзей не маунтятся различные USB-накопители. немного информации:

Код:
twix@twixed:~> uname -a
Linux twixed 2.6.27.25-0.1-pae #1 SMP 2009-07-01 15:37:09 +0200 i686 i686 i386 GNU/Linux
Код:
twix@twixed:~> dmesg | grep usb
usb 5-4: new high speed USB device using ehci_hcd and address 7
usb 5-4: no configurations
usb 5-4: can't read configurations, error -22
usb 5-4: new high speed USB device using ehci_hcd and address 8
usb 5-4: no configurations
usb 5-4: can't read configurations, error -22
usb 5-4: new high speed USB device using ehci_hcd and address 9
usb 5-4: configuration #1 chosen from 1 choice
usb 5-4: New USB device found, idVendor=0951, idProduct=1607
usb 5-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 5-4: Product: DataTraveler 2
usb 5-4: Manufacturer: Kingston
usb 5-4: SerialNumber: 000BFFB2A920851D0067??
usb-storage: device found at 9
usb-storage: waiting for device to settle before scanning
... и дальше ничего не происходит. кто ругается на конфиги? где их искать?

Код:
twix@twixed:~> lshal -m
Start monitoring devicelist:
-------------------------------------------------
18:43:12.080: usb_device_951_1607_000AEBFFB402A9251D0067__ added
18:43:12.139: usb_device_951_1607_000AEBFFB402A9251D0067___if0 added
18:43:12.144: usb_device_951_1607_000AEBFFB402A9251D0067___if0_scsi_host added
18:43:13.104: usb_device_951_1607_000AEBFFB402A9251D0067___if0_scsi_host_0 added
18:43:13.106: usb_device_951_1607_000AEBFFB402A9251D0067___if0_scsi_host_0_scsi_device_lun0 added
пальцы уже в кровь сточил, мотаясь по поисковикам и бордам. кто уже сталкивался, или просто подскажет в какую сторону копать?
 
07.08.2009 22:14  
OlegON
Ура, наконец-то я в графике :) Так обрадовался KDEшке, что проапгрейдил ее в консоль :) Но теперь все таки на 4.4 :) Это оффтоп. *79

Суть же, что монтируются они у тебя, скорее всего через udev, соответственно, ты рулезы прописал, как я писал где-то тут?
Цитата:
oops / # cd /etc/udev/rules.d/
oops rules.d # cat 10-mnt.rules
BUS=="usb", SUBSYSTEM=="block", KERNEL=="sd??", ACTION=="add", NAME="%k", GROUP="disk", RUN+="/usr/scripts/udev-flash-mount.sh add %k"
 
08.08.2009 12:46  
twix
Цитата:
Сообщение от OlegON
Суть же, что монтируются они у тебя, скорее всего через udev, соответственно, ты рулезы прописал, как я писал где-то тут?
да, все было прописано и проверено. да только вот каталоги не создавались, и устройства не маунтились. да что там! даже в лог ничего не падало.
 
08.08.2009 12:50  
twix
да! я так думаю, что проблема, видимо, аппаратная. потому что вот эта строчка:
Код:
config 1 has an invalid descriptor of length 0, skipping remainder of the config
появлялась везде.
и в убунте, с которой из-за этого ушел, и в федоре, которую попробовал, и в сьюзе, сидя на которой я создал эту тему, и в мандриве 2009, которая стоит сейчас, происходит то же самое.... )8

я так и не пойму, какие конфиги и кому нужны....
 
08.08.2009 13:18  
twix
нет аппаратную проблему приходится исключить, потому что мыша, фотокамера, вэбкамера, а так же юсб хаб подключились нормально. указанная ошибка в логах возникает исключительно при подключении накопителей...
опять вопрос: кто и на что ругается?
 
08.08.2009 20:21  
OlegON
Странно ты как-то дистрибутивы выбираешь... Особенно зюзя... Если что-то не работает, то проще выкинуть и поставить другую версию. К правке конфигов этот дистр не располагает. Поставь Gentoo :) А если уперся с этими разбираться, то есть варианты (точно не знаю, что за ругань)
1) Попробовать другую флешку
2) Посмотреть, что у тебя в ядре включено, то же автомонтирование там как-то поддерживалось. Готов конфиг выложить.
 
09.08.2009 14:42  
twix
Цитата:
Сообщение от OlegON
Странно ты как-то дистрибутивы выбираешь... Особенно зюзя... Если что-то не работает, то проще выкинуть и поставить другую версию. К правке конфигов этот дистр не располагает. Поставь Gentoo :) А если уперся с этими разбираться, то есть варианты (точно не знаю, что за ругань)
Генту еще выкачивать надо. остальные просто у меня дома есть на болванках с хакером.
Цитата:
1) Попробовать другую флешку
ни одни флешка или USB-веник не цепляются...
Цитата:
2) Посмотреть, что у тебя в ядре включено, то же автомонтирование там как-то поддерживалось. Готов конфиг выложить.
а вот тут уж хз, как смотреть ядро.

можно, конечно, напрячься, и вспомнить, как пересобирал ядра на фряхе 4.1... но это будет уж слишком.

сейчас попробую бубунту 9.04. так уж и быть - пускай вайн тормозит... )8
 
09.08.2009 17:21  
OlegON
ну не все дистры кладут рядом исходники своих ядер, но найти где-то (/usr/src/linux) файл .config и запустить
Цитата:
make menuconfig
совсем не так трудно, как пишут легенды... Тебе же не пересобирать, просто посмотреть для начала...
 
10.08.2009 08:34  
twix
теперь совсем все плохо... видимо, мать загибается, потому что на установленной системе ядро все чаще впадает в панику. по "волшебной" комбинации клавиш Alt+SysRq+S буферы на веник не сливаются - в логах об ошибке ничего нету. )8
различные лайв сиди и установщики тоже впадают в агонию при загрузке, не успев что-либо сообщить. некоторые, правда, выдают на монитор колл стеки и трейсы, которые мне ни о чем не говорят...
жаль... хорошая была компа. служила мне верой и правдой три года. *94
 
10.08.2009 09:52  
OlegON
Ну Magic SysRq на самом деле тоже в ядре включается... Если выберешь Gentoo - заводи ветку, подсказывать буду :) Ну и gentoo.ru никто не отменял, там народ отзывчивый.
 
 


Опции темы



Часовой пояс GMT +3, время: 03:25.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.