[ОТВЕТИТЬ]
Опции темы
29.08.2009 17:51  
Pyatak
Oracle 9i
Windows Server 2003 Enterprise Edition SP2

Делал всё в очередной раз как обычно: установка ОС, драйверов, Oracle Client 6i (да, да, хоть и не рекомендуется, но раньше тоже всегда ставил), Oracle Server 9i, патч 92070, создал листенер. Всё проходило как обычно, штатно, без ошибок. Приступаю к созданию БД, запускаю Database Configuration Assistant, указываю все параметры как обычно, в самом конце ставлю две галочки "создать БД" и "сохранить шаблон", нажимаю кнопку "готово", выскакивает окно "Summary", жму ОК в предвкушении начала создания БД... Но, облом, окно "Summary" просто закрывается и ничего не происходит, пробую еще и еще, прихожу к тому же результату. Убрал галочку "создать БД" и, о чудо, шаблон успешно сохранился. Тогда убрал "сохранить шаблон", поставил "создать БД" и опять ничего, окно "Summary" просто закрывается и ничего не происходит, ни каких ошибок, ни каких действий. Куда смотреть? Что делать?
 
29.08.2009 20:54  
OlegON
Home какой по умолчанию? Думается, что ССЗБ, бо не надо репортсы ставить. Это моя рекомендация из плюса была. И до сих пор ее поддерживаю.
sqlplus из консоли вызывается? Просто Пуск-Выполнить-cmd-sqlplus
Какой-то еще неожиданный софт стоит? Вроде антивируса? ОпенОффис? Или что-то еще, что могло Java-окружение задеть?
Кстати, дистр не пробовал менять?
 
30.08.2009 19:24  
Pyatak
Home серверный, sqlplus запускается, никакой софт не ставил, только ОС, драйвера и Oracle.
Имеешь ввиду дистр ОС или БД?
 
30.08.2009 20:17  
Arsen
есть что нибудь в алерт.лог?как работаешь на сервер, через рдп?
 
31.08.2009 00:29  
baggio
переустанови жаву... проблема в ней...
в момент когда нажимаешь ок - jawa процес в диспетчере появляется?
 
31.08.2009 07:20  
OlegON
Цитата:
Сообщение от Pyatak
Home серверный, sqlplus запускается, никакой софт не ставил, только ОС, драйвера и Oracle.
Имеешь ввиду дистр ОС или БД?
Дистр Oracle... Мож в нем/из него что-то не так поставил... Впрочем, варианты с RDP и побитой явой мне тоже понравились.
 
31.08.2009 10:26  
Pyatak
Работаю локально. Свежую Яву скачивал и ставил, не помогло. В диспетчере задач висит jre.exe
Более того, поставил винду заново, установив только драйвер сетевой карты и больше ни одного приложения. Поставил заново Oracle (только сервер 9i и патч), картина та же.
За ночь скачал дистрибутив девятки с сайта оракла, всё таки он у меня хранился на hdd и может чем-то повредился (уже и такая мысль мелькнула). А сейчас еще заметил на сайте "Patch Upgrade for Windows Server 2003 (32-bit) - requires 9.2.01 installation", качаю, посмотрим что получится. Но раньше-то я ставил именно этот свой дистрибутив именно на этот дистрибутив винды без всяких дополнительных патчей!
 
31.08.2009 11:18  
baggio
попробуй отключить сетевуху... и все не нужнок для работы железо... аудио ком порты и т.д. если все до этого работало значит дело в железках...
 
31.08.2009 14:28  
Pyatak
О, чудо! Процесс пошел.
Ставлю со свежескачанного дистрибутива и патча.
Хотя, задавая сейчас параметры БД заметил, что скорее всего ранее делал одну систематическую ошибку: я задаю файловую переменную ORACLE_BASE2, присваивая ей путь к БД, а потом везде в параметрах к переменной ORACLE_BASE дописываю циферку 2. Так вот, в одном месте, видимо, я дописывал эту самую циферку к переменной ORACLE_HOME, тем самым получалась не заданная переменная ORACLE_HOME2. Может и из-за этого ни ставилось, но почему не ругалось, вот вопрос. В общем, сейчас всё путем :)
 
 
Опции темы



Часовой пояс GMT +3, время: 17:31.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.