[ОТВЕТИТЬ]
Опции темы
29.09.2010 00:57  
reb00ter
Здравствуйте
предстоит обновить супермаг с 1.026.4sp2 до 1.027.5sp3
подскажите, какие проблемы и подводные камни могут всплыть при обновлении?
 
29.09.2010 01:18  
Vovantus
Цитата:
Сообщение от reb00ter
Здравствуйте
предстоит обновить супермаг с 1.026.4sp2 до 1.027.5sp3
подскажите, какие проблемы и подводные камни могут всплыть при обновлении?
недавно обновлялся с более древней версии. в процессе обновления, в общем-то, никаких серьёзных подводных камней не вылезло. удаляете супермаг, далее, последовательно устанавливаете все промежуточные версии, включая последний сервис-пак. можно и не все подряд, но кто знает, в какой версии произошли изменения в структуре табличек. из компонентов я выбирал только генератор БД. поставил, прогнал генератор, произвёл деинсталляцию СМ. подводный камень вылез в самом конце, когда из последнего дистрибутива были выбраны все необходимые компоненты. сервер супермага никак не хотел устанавливаться. как оказалось, в системе должен быть установлен .net Framework 3.5. в последствии произвёл перенос и расчёт тавародвижения и остатков, посчитал статистику, всё нормально :) а ещё позже повылазили фенечки новых версий, в виде глючного сервера приложений, подвисающего кассового модуля и т.д. всё это описано в соседних ветках форума. все глюки если и не решаемые в данный момент, то к ним можно привыкнуть. да и разработчики обещают исправить ошибки в ближайших сервис-паках. так что обновляйтесь, если что, поможем. тока бэкап обязательно сделайте перед этой процедурой, а ещё лучше, сразу образ системы ;)
 
29.09.2010 07:17  
Mtirt
Э, я бы проверила перед переустановкой наличие Net Framework 3.5 на всех компьютерах (и на клиентских тоже).
Ну и подумала об установке клиентской части оракла версии 9 или 10.
 
29.09.2010 08:46  
Vovantus
Цитата:
Сообщение от Mtirt
Ну и подумала об установке клиентской части оракла версии 9 или 10.
вот, это важно! вообще, можно обойтись и без ораклового клиента, но тогда придётся соединяться с базой через сервер приложений. а он глючит и не только у меня :(
 
29.09.2010 12:42  
Shlong
с 1.026.4sp2 до 1.027.5 переходили без промежуточных версий, ошибок не возникло... Следует тока обратить внимание на то, что узеру SUPERMAG сильно порезали права, даже кассовик не сможет стартонуть...
 
29.09.2010 13:44  
FILBOR
А оракл менять будете? Образ системы рулит :)
 
30.09.2010 20:34  
SMak
оракл стоит 10.2.04 его трогать не будем
из клиентских дистров есть 10201_client_win32 и ODT_10.1.04
первый нигде не использовали по причине ненадобности, второй стоит на паре машин, т.к. писали свои утилиты, работающие с базой напрямую...
вопрос 1:
Что правильнее установить всем 10201_client или ODT_10.1.04 или что-то третье?
вопрос 2:
Ставим на серверах 1.027.5, прогоняем генератор БД, ставим сп3, прогоняем скрипты. Так? Или сервис паки надо все последовательно?
 
30.09.2010 21:14  
OlegON
1. Вопрос правильности в данном случае ближе к тому, что у большинства установлено, а это клиент (не Instant).
2. Последовательно не надо. Обычно ставят все, включая паки, поскольку был пак, касающийся генератора БД в одной из версий, прогоняется генератор, потом скрипты пака.
 
01.10.2010 07:03  
Mtirt
Там по-моему и промежуточные версии не нужны.
Т.е. можно на 1.026.4 сразу запускать 1.027.5
Только еще, лучше перед обновлением сделать полную очистку аналитических таблиц.
В одной из промежуточных версий меняется их структура, если в таблицах есть данные, то обновление займет значительное время.
 
10.10.2010 16:29  
TrantiMoller
Имеется опыт перехода с 1.026.3 SP4 на 1.027.5 SP3... правда еще сопровождалось с переходом на 11-й оракл
без пормежуточных версии, обязательно полная очистка аналитических таблиц
Все прошло нормально, единственное, как говорилось выше криво работает сервер приложений (например, при выборе даты через календарь сервер приложений виснет и база отваливается), советую подключаться через оракл-клиент.
 
 


Опции темы



Часовой пояс GMT +3, время: 19:07.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.