[ТЕМА ЗАКРЫТА]
30.11.2010 14:02
twix
 
Имеются:
а) DHCP сервер, который работает на контроллере домена под управлением Windows Server 2003;
б) TFTP сервер с миниатюрным линуксовым образом ThinStation - там же;
в) тонкие клиенты Depo 151 с установленным Debian Lenny 5.04.

Что надо:
необходимо, чтобы тонкие клиенты получали с контроллера домена сетевые настройки и загрузочный образ, и подключались к терминальному серверу, указанному в настройках ThinStation.

Проблема:
долгий DHCP discovering, приводящий к невозможности успешной загрузки образа на тонком клиенте.
( PXE Boot оказывается терпеливее сетевого демона в линуховом образе, и поэтому честно загружает и запускает образ с TFTP. А вот линукс уже выдает 'system halted' на этапе получения IP-адреса из-за DHCP timeout. )

Интересный момент заключается в том, что сеть у нас везде гигабитная. Но на время тестирования тонкий клиент был подключен к сети через 100-мегабитный свитч. Так вот... через этот свитч загрузка пролетает "на ура", и через двадцать секунд мы имеем подключенное рабочее место на сервере терминалов, а при соединении напрямую - на 1 Гбит - мы получаем дичайшие задержки при получении сетевых настроек от DHCP.
Чтобы сразу отмести один из советов, скажу: не только этот тонкий клиент ведет себя подобным образом - PXE-загрузка с любого из компьютеров, подключенных к нашей сети, приводит к такому результату. Включение в цепь клиент-сервер 100-мегабитного свича решает проблему. Под виндами получение адресов и сетевых настроек происходит вполне нормально.
Уберем еще одно предположение: со стороны сервера соединение на порте Cisco 2960 зарезано до 100 Мбит (full duplex).

Вопрос:
что еще можно попробовать, чтобы выявить причину такого поведения и ее устранить?
30.11.2010 14:32
Stels
 
где-то в нете попадалось на proNovell • Главная страница вроде
там тоже что-то было с загрузкой по сети ...
несогласованы параметры сетевой на клиенте и свиче..
т.е. допустим Клиент 100 FULL duplex, а свич 100, но не фулл ...
как-то так ...
какие режимы для 1000 не знаю ..

Рекомендация была ставить настройки:1) не в Авто 2) одинаковые на обоих сторонах.

как это сделать в вашем случае - незнаю :(
30.11.2010 14:49
twix
 
Цитата:
Stels где-то в нете попадалось на proNovell • Главная страница вроде
там тоже что-то было с загрузкой по сети ...
несогласованы параметры сетевой на клиенте и свиче..
т.е. допустим Клиент 100 FULL duplex, а свич 100, но не фулл ...
как-то так ...
какие режимы для 1000 не знаю ..

Рекомендация была ставить настройки:1) не в Авто 2) одинаковые на обоих сторонах.

как это сделать в вашем случае - незнаю :(
на тонких клиентах в биосе настроек кот наплакал. самое крутое, что там можно сделать - поменять очередь загрузки...
30.11.2010 15:14
OlegON
 
А поставить между сервером и клиентами что-то, где через Wireshark пощупать, что там бегает в том и другом случае? Ну или на сервере (я не помню, заводится акула на винде или нет)
30.11.2010 17:29
AlexeyF
 
Действительно несогласованность настроек портов.
>со стороны сервера соединение на порте Cisco 2960 зарезано до 100 Мбит (full duplex)
Вот тут поподробнее. В промежутке между сервером и клиентами есть сиська ?
У неё на порту, который в сервер смотрит, стоит 100 Мбит (full duplex) ? А на сервере принудительно выставлено то же самое, или авто определение ?
Если что - порты в циску надо точно так же настраивать, как и порты на самой циске, иначе - будут приключения. Порты циски, которые смотрят в сторону гигабитных свичей - так же надо принудительно режим прописать + и на самих свичах принудительно.
30.11.2010 19:24
twix
 
Цитата:
AlexeyF Действительно несогласованность настроек портов.
>со стороны сервера соединение на порте Cisco 2960 зарезано до 100 Мбит (full duplex)
Вот тут поподробнее. В промежутке между сервером и клиентами есть сиська ?
У неё на порту, который в сервер смотрит, стоит 100 Мбит (full duplex) ? А на сервере принудительно выставлено то же самое, или авто определение ?
Если что - порты в циску надо точно так же настраивать, как и порты на самой циске, иначе - будут приключения. Порты циски, которые смотрят в сторону гигабитных свичей - так же надо принудительно режим прописать + и на самих свичах принудительно.
да, сиська имеется. модели WS-C2960-24TC-L, 24-портовый коммутатор. а так же, между ней и клиентами имеются "умные" свичи D-link DGS-11xx/12xx - разное их количество и модели в зависимости от удаленности от серверной комнаты.
скорость и режим работы портов на сиське я выставил самостоятельно, в ходе экспериментов. изначально все было на автомате - как физические порты, так и транк-интерфейс. на самом сервере долбаный Intel TEAM вообще не дает возможности себя настроить - там как был, так и остался автомат. единственное, что сам этот транк работает на скорости 200 Мбит/с - по сотне с каждого физического интерфейса.

послезавтра попробую поиграться с настройками портов на коммутаторах - может, если все привести к единому виду, заработает нормально. только нам 100 Мбит не хватит... надо будет гигабит выставлять.
02.12.2010 17:08
AlexeyF
 
Результат сообщи, из спортивного интереса?
02.12.2010 18:14
twix
 
Цитата:
AlexeyF Результат сообщи, из спортивного интереса?
увы, не было сегодня времени перенастроить и проверить...
11.01.2011 12:23
twix
 
возвращаемся к нашим баранам.
проблема осталась, как я ни игрался с настройками портов.
в выходные запускал тонкого клиента без проблем. сейчас опять траблы. даже на ста МБитах... есть предположение, что кто-то из сетевых клиентов сильно гадит в сеть. чем из стандартных средств виндовс 2003 и 2008 можно помониторить загрузку сети?
11.01.2011 16:17
twix
 
есть определенная уверенность в том, виноват STP на cisco 2960
чейчас курю интернеты с целью выяснить возможность безопасного отключения этой фичи на всех портах
11.01.2011 16:39
AlexeyF
 
Стандартными найти загадившего - не знаю как. Для таких целей обычно снифферами пользоваться приходится. На свиче (если есть такая возможность) на какойто порт отправляешь весь трафик коммутатора, на этот порт садишь комп со снифером - и смотришь что там награбится удастся.
CommView
CommView :: Программы :: Компьютерный форум Ru.Board
На тему снифферов
Ошибка :: Компьютерный форум Ru.Board
11.01.2011 16:41
AlexeyF
 
А просто покажи свои настройки на порту цисковском - может кто что нехорошее заметит.
12.01.2011 08:26
twix
 
Цитата:
AlexeyF А просто покажи свои настройки на порту цисковском - может кто что нехорошее заметит.
вот такая конфа сейчас крутится на сиське:

Код:
Current configuration : 5706 bytes
!
version 12.2
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname C2960
!
enable secret 5 фывафывафыва
enable password 7 фываыфваыфва
!
username alexn privilege 15 password 7 фывафывафыва
username navi privilege 15 password 7 ыфваыфвыфва
aaa new-model
aaa authentication login default local-case
aaa authorization exec default local
!
aaa session-id common
clock timezone MSK 3
clock summer-time MSK-DST recurring last Sun Mar 2:00 last Sun Oct 2:00
system mtu routing 1500
ip subnet-zero
!
ip domain-list chuvashavtodor.ru
no ip domain-lookup
ip name-server 192.168.0.2
!
!
!
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
 description dc1
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface Port-channel2
 description exch2
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface Port-channel3
 description exch1
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface Port-channel4
 description fs1
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface Port-channel5
 description ws2
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface Port-channel6
 description ws1
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
 description DC1
 switchport access vlan 2
 switchport mode access
 channel-group 1 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/2
 description DC1
 switchport access vlan 2
 switchport mode access
 channel-group 1 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/3
 description Exch2
 switchport access vlan 2
 switchport mode access
 channel-group 2 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/4
 description Exch2
 switchport access vlan 2
 switchport mode access
 channel-group 2 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/5
 description exch1
 switchport access vlan 2
 switchport mode access
 channel-group 3 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/6
 description exch1
 switchport access vlan 2
 switchport mode access
 channel-group 3 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/7
 description fs1
 switchport access vlan 2
 switchport mode access
 channel-group 4 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/8
 description fs1
 switchport access vlan 2
 switchport mode access
 channel-group 4 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/9
 description ws2
 switchport access vlan 2
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/10
 description ws2
 switchport access vlan 2
 switchport mode access
 channel-group 5 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/11
 description ws1
 switchport access vlan 2
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/12
 description ws1
 switchport access vlan 2
 switchport mode access
 channel-group 6 mode on
 spanning-tree portfast disable
!
interface GigabitEthernet0/13
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast disable
!
interface GigabitEthernet0/14
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast disable
!
interface GigabitEthernet0/15
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast disable
!
interface GigabitEthernet0/16
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast disable
!
interface GigabitEthernet0/17
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast disable
!
interface GigabitEthernet0/18
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast disable
!
interface GigabitEthernet0/19
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast disable
!
interface GigabitEthernet0/20
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast disable
!
interface GigabitEthernet0/21
 description c2821-gi0 <--> c2960-gi21
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet0/22
 description c2821-gi1 <--> c2960-gi22
 switchport trunk native vlan 3
 switchport mode trunk
!
interface GigabitEthernet0/23
 description VT-ADSL <--> c2960-gi23
 switchport access vlan 3
 switchport mode access
!
interface GigabitEthernet0/24
 description Eterway <--> c2960-gi24
 switchport access vlan 4
 switchport mode access
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan2
 ip address 192.168.0.253 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.0.1
no ip http server
access-list 10 permit 192.168.0.2
snmp-server community avtodor RW 10
snmp-server location Russia, Chuvashia
snmp-server contact Russia, Chuvashia, Cheboksary
snmp-server enable traps snmp coldstart warmstart
snmp-server host 192.168.0.2 informs version 2c cap-communication
snmp-server host 192.168.0.2 version 2c cap-communication
radius-server source-ports 1645-1646
!
control-plane
!
!
line con 0
 exec-timeout 60 0
 password 7 фывафыва
 logging synchronous
 history size 256
line vty 0 4
 exec-timeout 2880 0
 password 7 фываыфва
 logging synchronous
 history size 256
line vty 5 15
 exec-timeout 2880 0
 password 7 фывафывыва
 logging synchronous
 history size 256
!
ntp server 192.168.0.2
end
я в настройке сисек не силен. изучаю интернеты, произвожу какие-то изменения, но результатов это не дает. что-то кардинально менять сразу я боюсь... будет оччень неприятно, если посреди рабочего дня вся сеть отвалится...
12.01.2011 10:21
twix
 
кое-что проклюнулось:
1. включил stp portfast на всех портах cisco2960 -> проблема осталась
2. обнаружил, что кабель, которым подключается тонкий клиент, воткнут в d-link dgs3100
3. отключил stp на всех портах dgs3100 -> сеть упала
4. ребутнул dgs3100 - сеть поднялась, конфиг старый
5. переткнул кабель от ТК в cisco2960 -> присвоение IP и загрузка ThinStation проходит моментально и без проблем

наводит на мысли о закольцовке на каком-то из этажей... методом тыка буду определять, на каком именно.
попробую поискать информацию о d-link'ах на тему настройки того же portfast'а... пока выставил режим в rstp, но ничего не поменялось
12.01.2011 14:25
twix
 
проблема оказалась глубже, чем я думал...
после включения portfast на портах 1-22 сиськи 2960 и отключения stp на dlink'е, у нас отвалилось соединение для филиалов. только сейчас, с помощью матерых специалистов провайдера, удалось выяснить, что девайсина с их стороны обнаруживала кольцо и закрывала соединение на пять минут. интересен тот факт, что перезапуск всех наших сетевых устройств с восстановлением предыдущих конфигураций проблему не решил. в данный момент мы работаем с включенным stp, тормозным dhcp и отсутствием контроля за флудом со стороны провайдера. долго так продолжаться не может, поэтому в срочном порядке я и Я курим сигаретку в раздумьях о причинах происходящего и путях их устранения...
12.01.2011 18:10
AlexeyF
 
Кольцо лечится везением, расчёсыванием проводов на коммутаторах и попеременным отключением сегментов сети, с рисованием топологии.
13.01.2011 11:19
twix
 
связались с представителями D-Link'а, их специалисты подсказали аналог сиськового portfast'а, после включения которого клиенты работают нормально.
кольцо, однако, все-равно надо найти и разорвать, ибо не дело... для этого в D-Link'ах, по словам этих же спецов, есть соответствующий функционал, который я пока не нашел.
14.01.2011 08:43
bob
 
Почитай про Traffic Control (Storm Control) в коммутаторах D-Link DES-2108, или лучше D-Link DES-3010G для примера. В районе 20-25 тысяч можно купить очень приличные коммутаторы.
17.01.2011 16:50
twix
 
кольцо нашлось...
отключал STP на всех портах поочередно. после отключения одного из них сеть упала. пошел к железке - выдернуть кабель... выдернул его из порта - еще один порт погас, сеть появилась; воткнул обратно - сеть упала, второй порт загорелся... в общем, не понятно, кто, когда и зачем сделал нехорошую вещь - воткнул кабелек в порт, по правилам уложил его в канал, увел внутрь шкафа, потом вывел обратно, и воткнул в еще один порт...
вот такие пироги
17.01.2011 17:00
Dim
 
происки обиженных?
17.01.2011 17:21
bob
 
Цитата:
twix кольцо нашлось...
отключал STP на всех портах поочередно. после отключения одного из них сеть упала. пошел к железке - выдернуть кабель... выдернул его из порта - еще один порт погас, сеть появилась; воткнул обратно - сеть упала, второй порт загорелся... в общем, не понятно, кто, когда и зачем сделал нехорошую вещь - воткнул кабелек в порт, по правилам уложил его в канал, увел внутрь шкафа, потом вывел обратно, и воткнул в еще один порт...
вот такие пироги
Вот для таких случаев нормальные коммутаторы и нужны. У нас было пару случаев.
Один раз в здании Торг-развл. центра (сеть клали кое-как, куча свичей) тоже закольцевали. так сеть на полдня в трех зданиях легла. Второй раз свич в офисе переклинило - и тоже самое. ПОсле покупки в каждое из трех зданий нормальных коммутаторов проблемы исчезли. просто отключается глючный сегмент сети и все. А с ним разобраться гораздо проще.
01.02.2011 10:40
twix
 
обнаружилась еще одна проблема...
на четвертом этаже стоял 48-портовый управляемый концентратор D-Link DGS3100, точно такой же, что стоит в серверной. на четвертом этаже и выше наблюдались аналогичные проблемы с загрузкой тонких клиентов. получить доступ к панели управления девайсом не удалось... даже после сброса. так что он был заменен на два 24-портовых неуправляемых свитча того же производителя. проблема исчезла.
после вскрытия обнаружились два неисправных вентилятора и слой пыли толщиной с палец. после чистки и замены ветродуек девайс так и не стал функционировать нормально... сеть раздавать может, но сам же вызывает проблемы с симптоматикой закольцовки. так что вот. (8
Опции темы


Часовой пояс GMT +3, время: 01:44.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.