[ОТВЕТИТЬ]
04.11.2012 19:09
pvorobev
 
Цитата:
OlegON неплохо бы пояснить, в чем проблема сейчас. листенер не работает? и 11 или 10 все же? Если 10, что мы делаем в этой теме?

Добавлено через 5 минут 15 секунд
в общем, делаем так.
1) listener.ora безвременно поправленный - убиваем
2) службу listener перезапускаем
3) перезапускаем службу базы
4) смотрим lsnrctl status и приводим ее вывод тут
5) берем у whitewizard tnsnames.ora и правим там базу
6) выводим сюда что говорит tnsping имя_базы
как привести содержимое cmd ?
04.11.2012 19:15
OlegON
 
Цитата:
pvorobev как привести содержимое cmd ?
может... подумаете над сменой профессии?



и Enter
04.11.2012 19:15
whitewizard
 
В cmd пишем
Lsnrctl status > c:\1.txt
04.11.2012 19:17
OlegON
 
Цитата:
whitewizard В cmd пишем
Lsnrctl status > c:\1.txt
неправильный совет :(
Некоторые софтины могут выводить в stderr, куда, собственно, ошибки сваливаются у правильных. А ты только stdout перенаправляешь.
04.11.2012 19:19
pvorobev
 
после Lsnrctl status

LSNRCTL for 32-bit Windows: Version 10.2.0.5.0 - Production on 04-NOV-2012 19:18:48

Copyright (c) 1991, 2010, Oracle. All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
STATUS of the LISTENER
------------------------
Alias LISTENER
Version TNSLSNR for 32-bit Windows: Version 10.2.0.5.0 - Production
Start Date 04-NOV-2012 19:13:46
Uptime 0 days 0 hr. 5 min. 2 sec
Trace Level off
Security ON: Local OS Authentication
SNMP OFF
Listener Log File C:\oracle\product\10.2.0\db_1\network\log\listener.log
Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=server.PETROVSKII.TK)(PORT=1521)))
The listener supports no services
The command completed successfully

после tnsping dimetra1

TNS Ping Utility for 32-bit Windows: Version 10.2.0.5.0 - Production on 04-NOV-2012 19:20:57

Copyright (c) 1997, 2010, Oracle. All rights reserved.

Used parameter files:
C:\oracle\product\10.2.0\db_1\network\admin\sqlnet.ora


Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION =
TNS-12533: TNS:illegal ADDRESS parameters
04.11.2012 19:21
whitewizard
 
В данном случае все в текстовик запишется нормально

Добавлено через 1 минуту 18 секунд
Он еще и в домене
Напиши host=server
04.11.2012 19:44
pvorobev
 
куда копать дальше?
04.11.2012 19:55
whitewizard
 
Укажи вместо имени server его ip адрес везде
Но в листенере и тнснэйм, чтоб адреса одинаковые были.
Потом перепусти службы листенере и базы.
И самое главное - не забыл в ременной path путь к новому ораклу в начале прописать?
04.11.2012 19:59
pvorobev
 
Цитата:
whitewizard Укажи вместо имени server его ip адрес везде
Но в листенере и тнснэйм, чтоб адреса одинаковые были.
Потом перепусти службы листенере и базы.
И самое главное - не забыл в ременной path путь к новому ораклу в начале прописать?
таже фигня служба листнера не запускается(((( в 9-ке работало нормально после перехода фиг(

Добавлено через 2 минуты 14 секунд
без файла listener.ora служба запускается но к базе не подключиться(
04.11.2012 20:38
OlegON
 
убей listener.ora, поверь уже... и tnsnames.ora убей, потом через netca создай новый tnsnames.ora, но да, никакого домена вписывать не надо. IP-адрес, причем не 127.0.0.1
надеюсь, это не контроллер домена?
04.11.2012 22:13
pvorobev
 
Цитата:
OlegON убей listener.ora, поверь уже... и tnsnames.ora убей, потом через netca создай новый tnsnames.ora, но да, никакого домена вписывать не надо. IP-адрес, причем не 127.0.0.1
надеюсь, это не контроллер домена?
На компе стоит Windows Server 2003, там же поднят домен. На нем же был Oracle 9, соответственно после перехода на Oracle 10g начался данный гемор.
В 9-ке достаточно было tnsnames.ora отредактировать и все работало без проблем, тут же мутатень какая-то((( хоть бы инструкция была по листенеру((( как и что делать при переходе с 9-ки на 10-ку
05.11.2012 07:55
OlegON
 
увы, но проблема тут не в 10, а в "администраторе". но решение я написал выше.
05.11.2012 12:23
Dim
 
вчера на работающей базе тоже получил 12514... сделал рестарт сервиса базы, после запуска службы, в администраторе сервера приложений при активации БД выдало такую ошибку... при этом tnsping до базы проходил нормально, sqlplus из всех хоумов тоже цеплялся нормально. вылечилось удалением базы из сервера приложений и добавлением ее обратно... что это было так и не понял...
05.11.2012 12:43
OlegON
 
Цитата:
Dim что это было так и не понял...
ответ в алерте, скорее всего. помойка на винде никогда не способствовала нормальной работе.
05.11.2012 12:53
Dim
 
винда свежая... в алерте чисто
05.11.2012 13:28
OlegON
 
Цитата:
Dim sqlplus из всех хоумов
Цитата:
Dim винда свежая... в алерте чисто
ты уж определись :)
05.11.2012 13:45
Dim
 
стоит БД, клиент, репортсы
05.11.2012 14:01
whitewizard
 
Цеплялся нормально sqlplus или sqlplusw?
05.11.2012 14:08
OlegON
 
Цитата:
Dim стоит БД, клиент, репортсы
= помойка
05.11.2012 14:10
Dim
 
Цитата:
whitewizard Цеплялся нормально sqlplus или sqlplusw?
и тот и тот
05.11.2012 14:10
Dim
 
Цитата:
OlegON = помойка
знаю твое отношение к этому вопросу
05.11.2012 14:21
konst
 
Цитата:
Dim стоит БД, клиент, репортсы
разве надо ставить отдельно клиента?
06.11.2012 13:21
pvorobev
 
Цитата:
OlegON увы, но проблема тут не в 10, а в "администраторе". но решение я написал выше.
сделал откат и попробовал все с начало, все встало нормально спасибо за советы всем


Опции темы


Часовой пояс GMT +3, время: 07:29.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.