[ОТВЕТИТЬ]
03.03.2016 13:24
KirillHome
 
Цитата:
Tigra_N Файлы для загрузки/выгрузки для ТСД. оба файла получены "законным путем", т.е. один из них выгружен из программы в терминал, другой — получен из ТСД.
И где нет преобразования строки в число?

Цитата:
Tigra_N Еще хотелось бы сворачивать строки по коду номенклатуры, в развернутом виде возникают проблемы в документах.
В документ передаются свёрнутые строки.
Я же раньше писал об этом.
На всякий случай ещё раз показываю - вот оно:
Код:
&НаСервере
Функция СоздатьДокументНаСервере()
	НовДок = Документы[Объект.ТипДокументаДляЗагрузки].СоздатьДокумент();
	НовДок.Организация = Объект.Организация;
	НовДок.Склад = Объект.Склад;
	НовДок.Дата = ТекущаяДата();
	
	ТЗ = Новый ТаблицаЗначений;
	ТЗ = Объект.ТоварыИзТСД.Выгрузить();
	ТЗ.Свернуть("Номенклатура","Количество");
	Объект.ТоварыИзТСДСвернуты.Очистить();
	Объект.ТоварыИзТСДСвернуты.Загрузить(ТЗ);
	
	Для Каждого Стр из Объект.ТоварыИзТСДСвернуты Цикл
		СтрТовар = НовДок.Товары.Добавить();
		СтрТовар.Номенклатура = Стр.Номенклатура;
		СтрТовар.ЕдиницаИзмерения = Стр.Номенклатура.ЕдиницаИзмерения;
		СтрТовар.КоличествоЕдиницИзмерения = Стр.Количество;
		СтрТовар.Количество = Стр.Количество;
	КонецЦикла;
	НовДок.Записать();
	Объект.ДокументСсылка = НовДок.Ссылка;
	Возврат НовДок.Ссылка;
КонецФункции
Если ты говоришь о том, что в документ переносятся строки через "Скопировать строки" или "Сохранить в список товаров" - то да, на текущий момент не происходит сворачивания.
Если тебе НЕОБХОДИМЫ именно эти функции, и НЕОБХОДИМО, что бы они выдавали свёрнутый результат - то надо сказать об этом.
03.03.2016 15:40
Tigra_N
 
Цитата:
В документ передаются свёрнутые строки.
Я же раньше писал об этом.
Наверное мы говорим о разных вещах. Говоря о сворачивании, я имел в виду номенклатуру с одинаковым наименованием переносить в документ как одно наименование, а количество уже суммировать. Смотри скриншот IN_OUT, я подчеркнул наименования. они повторяются, нужно объединить их в одно (получить одну строку, где штрих-код будет 8697817872139, наименование — "первый тестовый товар", а количество должно быть равным 2,188)
Цитата:
И где нет преобразования строки в число?
На всякий случай ещё раз показываю - вот оно:
Код:
СтрТовар.КоличествоЕдиницИзмерения = Стр.Количество;
СтрТовар.Количество = Стр.Количество;
где-то здесь возникают ошибка, в результате сообщение на скриншоте
Цитата:
Если ты говоришь о том, что в документ переносятся строки через "Скопировать строки" или "Сохранить в список товаров" - то да, на текущий момент не происходит сворачивания.
Если тебе НЕОБХОДИМЫ именно эти функции, и НЕОБХОДИМО, что бы они выдавали свёрнутый результат - то надо сказать об этом.
не имею понятия о чем ты говоришь
Миниатюры
Нажмите на изображение для увеличения
Название: УправлениеТСДExt_error_kolichestvo.png
Просмотров: 150
Размер:	107.7 Кб
ID:	7066   Нажмите на изображение для увеличения
Название: IN_OUT.png
Просмотров: 161
Размер:	44.0 Кб
ID:	7067  
03.03.2016 16:43
KirillHome
 
Так, теперь понял.
Рассказываю снова свою логику:
У нас есть текстовый файл (из ТСД), в котором может быть очень-очень много строк.
Для контроля "всё или не всё закачалось обработкой" на странице загрузки из ТСД - показывает то, что считалось (можно сверить по количеству строк, по любой строке и т.д.). И, к стати, с этой же целью (контроль) не удаляется автоматически загруженный файл, а только спрашивается у пользователя - "Удалить или нет?".
А уже при создании на основании этого документа (указываем "Тип документа", нажимаем "Загрузить в документ") - в документ идёт "свёрнутое" количество - т.е. в данном примере в документ уйдёт одна строка, в которой будет товар "первый тестовый товар" в количестве 2.188кг


Сегодня вечером сяду, сделаю ряд проверочных тестов, сниму скриншоты - и всё выложу сюда. ОК?
03.03.2016 17:00
Tigra_N
 
Цитата:
Для контроля "всё или не всё закачалось обработкой" на странице загрузки из ТСД - показывает то, что считалось (можно сверить по количеству строк, по любой строке и т.д.). И, к стати, с этой же целью (контроль) не удаляется автоматически загруженный файл, а только спрашивается у пользователя - "Удалить или нет?".
я переделал кое-что в твоей обработке. одним из изменений было закомменторивание удаления файла.
Цитата:
А уже при создании на основании этого документа (указываем "Тип документа", нажимаем "Загрузить в документ") - в документ идёт "свёрнутое" количество - т.е. в данном примере в документ уйдёт одна строка, в которой будет товар "первый тестовый товар" в количестве 2.188кг
я не знаю как у тебя работает, но у меня в документ, как ты мог уже заметить, идет не свернутым, см. вложение в предыдущем сообщении
03.03.2016 17:10
Tigra_N
 
в предыдущем сообщении я написал, что не свернуты строки в документе, но не показал на примере. вот скриншот документа "Возврат поставщику". как видишь одна номенклатура, но две строки.
Миниатюры
Нажмите на изображение для увеличения
Название: УправлениеТСДExt_ne_svernuto.png
Просмотров: 120
Размер:	91.3 Кб
ID:	7068  
03.03.2016 17:41
KirillHome
 
Цитата:
Tigra_N я переделал кое-что в твоей обработке. одним из изменений было закомменторивание удаления файла.

я не знаю как у тебя работает, но у меня в документ, как ты мог уже заметить, идет не свернутым, см. вложение в предыдущем сообщении
Тогда показывай текст функции "СоздатьДокументНаСервере"
Потому что у меня - сворачивает.
Миниатюры
Нажмите на изображение для увеличения
Название: Загузка со свёрнутыми строками.jpg
Просмотров: 115
Размер:	347.0 Кб
ID:	7069  
03.03.2016 18:14
Tigra_N
 
Цитата:
Тогда показывай текст функции "СоздатьДокументНаСервере"
Потому что у меня - сворачивает.
Извини, ты совершенно прав, все сворачивается, у меня несколько копий твоей обработки. я загрузил не самую последнюю, поэтому у меня не сворачивалось. я скопирую последнюю версию на флешку, чтобы дома просмотреть. завтра отпишусь.
еще раз извини за неудобства.
04.03.2016 01:15
KirillHome
 
Что бы ещё больше запутать - новая версия.

Список изменений:
1) Изменён заголовок окна (добавлен номер версии)
2) Появилась вкладка "Настройки" (по хорошему - её бы скрыть и сделать кнопку "Настройки", по которой она открывалась бы. Ну да ладно).
3) Принципиально поменялись настройки. Можно выбрать - "Предлагаемый тип операции" (при чтении из ТСД), сворачивать или нет строки по каждой конкретной операции, очищать автоматически считанную информацию из "файла ТСД" (да/нет/Спросить), очищать автоматически табличную часть загруженную из ТСД при создании документа (да/нет/Спросить), как выгружать код весового товара - с префиксом или без, как выглядят полученные из ТСД данные о весовом товаре (Префикс + Код или Префикс + Код + Вес).
4) Убрана птичка "Выгружать (для весовых товаров) код с префиксом"

Соответственно, поменялось много чего внутри по обработке этого.

Что надо сделать (мне)
Сделать кнопку "Сохранить настройки" (сейчас сохраняются при закрытии формы), сделать кнопку "сбросить настройки".

Что надо сделать (тебе)
Покритиковать внешний вид, подумать - что ещё можно "прицепить" (какие-то печатные формы? дополнительные поля в настройках?).

Во вложении - и новая версия, и внешний вид вкладки "Настройки"
Миниатюры
Нажмите на изображение для увеличения
Название: Настройки.jpg
Просмотров: 130
Размер:	216.6 Кб
ID:	7071  
Вложения
Тип файла: zip УправлениеТСДExt.zip (63.6 Кб, 58 просмотров)
09.03.2016 18:22
Tigra_N
 
Цитата:
Что бы ещё больше запутать - новая версия.
Новая версия очень понравилась. сделал кое-какие изменения.
Цитата:
Изменён заголовок окна (добавлен номер версии)
не смог разобраться как меняется версия
На вкладке "Выгружаемые из ТСД товары"
Нет возможности выделить несколько строк. Я так понимаю, у этой таблицы стоит атрибут "только для чтения"
Вкладка Загружаемый документ
Зачем он нужен?
Вкладка "Настройка"
После чтения данных из терминала, независимо от настроек все равно спрашивает Удалить или нет.
Вложения
Тип файла: zip УправлениеТСДExt_ver1.1.zip (36.2 Кб, 48 просмотров)
09.03.2016 21:37
KirillHome
 
Цитата:
Tigra_N Новая версия очень понравилась. сделал кое-какие изменения.
Во вложении, не смотря на название, оказалась обработка с (отображаемым в конфигурации) именем УправлениеВесамиUnitech. Так что буду отвечать на вопросы о той, что выложил я.


Цитата:
Tigra_N не смог разобраться как меняется версия
Версия, отображаемая в заголовке формы - см. процедуру ПриСозданииНаСервереExt
Код:
	Объект.Версия = "0.09";
	ЭтаФорма.АвтоЗаголовок = Ложь;
	ЭтаФорма.Заголовок = "Управление ТСД (внешняя)"+" ver."+Объект.Версия;

Цитата:
Tigra_N На вкладке "Выгружаемые из ТСД товары"
Нет возможности выделить несколько строк. Я так понимаю, у этой таблицы стоит атрибут "только для чтения"
Да, управление доступностью происходит в процедуре ПолучитьДанныеИзТСДExt
В начале указано:
Код:
	Элементы.ТоварыИзТСД.Доступность = Истина;
В конце чтения файла
Код:
	Элементы.ТоварыИзТСД.Доступность = Ложь;
	Файл.Закрыть();
Сделано для того, что бы пользователь (по злобе ли, или нет) не смог изменить считанные из ТСД данные (да, я не знаю, как разрешить выделять строки, но при этом не дать изменять строки).


Цитата:
Tigra_N Вкладка Загружаемый документ
Зачем он нужен?
Это "хвост" из оригинальной обработки.
Вообще, согласно документации (Руководство пользователя SuperKit Mobile_18Х), есть разные режимы работы терминала - "Инвентаризация без документов", "Инвентаризация с заголовками (с документами)", "Накладные".
Ну, и в "СТРУКТУРА ФАЙЛОВ ОБМЕНА ПРОГРАММЫ SuperKit Mobile" есть такое:
Цитата:
Запись заголовка накладной (Префикс записи «I»)

Структура:
<I>;<НОМЕР НАКЛАДНОЙ>;<ТИП НАКЛАДНОЙ>
Тип данных:
<НОМЕР НАКЛАДНОЙ> - 64 символа
<ТИП НАКЛАДНОЙ> - “0” – накладная поставщика, “1” – расходная, “2” – заказ, “3” – приходная накладная, “4” – накладная на перемещение.
Получается, что (по идее) мы можем как выгрузить в ТСД документ, так и получить его оттуда.
Так что, думаю, данная вкладка предназначена для работы с такими документами.


Цитата:
Tigra_N Вкладка "Настройка"
После чтения данных из терминала, независимо от настроек все равно спрашивает Удалить или нет.
Да, согласен, ошибка.
Опять же, процедура ПолучитьДанныеИзТСДExt
Стоит:
Код:
	Если ОтсутствиеОшибок Тогда
		Если НаличиеСтрок = Истина Тогда
			Ответ = Вопрос("Удалить файл из ТСД "+Объект.ФайлЗагрузкиИзТСД+"?",РежимДиалогаВопрос.ДаНет,0);
			Если Ответ = КодВозвратаДиалога.Да Тогда
				УдалитьФайлы(Объект.ФайлЗагрузкиИзТСД);
			КонецЕсли;
			ЭтаФорма.Элементы.ТипДокументаДляЗагрузки.Доступность = Истина;
		Иначе
			ТекстСообщения = НСтр("ru = 'В файле нет строк для загрузки в 1с'");
			ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
		КонецЕсли;
	КонецЕсли;
Должно быть
Код:
	Если ОтсутствиеОшибок Тогда
		Если НаличиеСтрок = Истина Тогда
			Если Объект.УдалятьФайлПослеЗагрузки="Спросить" Тогда
				Ответ = Вопрос("Удалить файл из ТСД "+Объект.ФайлЗагрузкиИзТСД+"?",РежимДиалогаВопрос.ДаНет,0);
				Если Ответ = КодВозвратаДиалога.Да Тогда
					УдалитьФайлы(Объект.ФайлЗагрузкиИзТСД);
				КонецЕсли;
			ИначеЕсли Объект.УдалятьФайлПослеЗагрузки="Да" Тогда
				УдалитьФайлы(Объект.ФайлЗагрузкиИзТСД);
			КонецЕсли;
			ЭтаФорма.Элементы.ТипДокументаДляЗагрузки.Доступность = Истина;
		Иначе
			ТекстСообщения = НСтр("ru = 'В файле нет строк для загрузки в 1с'");
			ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
		КонецЕсли;
	КонецЕсли;
10.03.2016 09:36
Tigra_N
 
Цитата:
Во вложении, не смотря на название, оказалась обработка с (отображаемым в конфигурации) именем УправлениеВесамиUnitech. Так что буду отвечать на вопросы о той, что выложил я.
Параллельно работаю над несколькими задачами, поэтому у меня такая путаница.
Цитата:
Версия, отображаемая в заголовке формы - см. процедуру ПриСозданииНаСервереExt
спасибо за подсказку, буду менять, чтобы не путаться
Цитата:
Сделано для того, что бы пользователь (по злобе ли, или нет) не смог изменить считанные из ТСД данные (да, я не знаю, как разрешить выделять строки, но при этом не дать изменять строки).
в большинстве случаев пользователь даже не догадается, но будет не совсем правильно давать ему такую возможность. может на форме добавить какую-нибудь кнопку для выделения строк программно?
Цитата:
Это "хвост" из оригинальной обработки.
я так и понял, но как его сделать невидимым? в свойствах этой вкладки убираю галочку "Видимость", но его все равно видно
Цитата:
Должно быть
я поменяю код процедуры на этот и выложу последнюю версию обработки.
Вложения
Тип файла: rar УправлениеТСДExt_ver1.1.rar (63.3 Кб, 36 просмотров)
10.03.2016 09:38
Tigra_N
 
Цитата:
я поменяю код процедуры на этот и выложу последнюю версию обработки.
выложил, не поменяв, потому, что не было 1с под рукой. потом поменяю и выложу
10.03.2016 10:06
KirillHome
 
Цитата:
Tigra_N в большинстве случаев пользователь даже не догадается, но будет не совсем правильно давать ему такую возможность. может на форме добавить какую-нибудь кнопку для выделения строк программно?
Объясни, для чего надо "выделять несколько строк".
После этого будем думать, как это решить.

Цитата:
Tigra_N я так и понял, но как его сделать невидимым? в свойствах этой вкладки убираю галочку "Видимость", но его все равно видно
Странно, но у меня она не видима (см. вложение)

Цитата:
Tigra_N я поменяю код процедуры на этот и выложу последнюю версию обработки.
Выкладывай, будем смотреть.
Миниатюры
Нажмите на изображение для увеличения
Название: Отсутствие вкладки Документы.jpg
Просмотров: 86
Размер:	143.2 Кб
ID:	7090  
10.03.2016 11:06
Tigra_N
 
Цитата:
Объясни, для чего надо "выделять несколько строк".
После этого будем думать, как это решить.
Нужно выделить строки для копирования. Когда таблица в режиме "Только для чтения", копируется только последняя строка, так как выделена только она. Я хочу программно выделить все строки, но чтобы для пользователя таблица все же оставалась в режиме "Только для чтения"
Миниатюры
Нажмите на изображение для увеличения
Название: УправлениеТСДExt_SelectAll.png
Просмотров: 88
Размер:	53.7 Кб
ID:	7091  
Вложения
Тип файла: rar УправлениеТСДExt_ver0.10.rar (63.8 Кб, 30 просмотров)
10.03.2016 15:00
KirillHome
 
Цитата:
Tigra_N Нужно выделить строки для копирования. Когда таблица в режиме "Только для чтения", копируется только последняя строка, так как выделена только она. Я хочу программно выделить все строки, но чтобы для пользователя таблица все же оставалась в режиме "Только для чтения"
Понял.
Вроде бы даже разобрался с выделением. Но - есть "засада".
Дело в том, что из ТСД мы получаем строки "не свёрнуто", и, соответственно, так же отображаем.
Получается, что и копировать мы можем "развёрнуто".

Есть совсем дурацкий вариант:
1) Добавить на форму не только ТоварыИзТСД, но и ТоварыИзТСДСвернуто.
2) Разместить кнопки копирования и на одной ТЧ, и на другой.

Мне он не нравится, но на всякий случай я его сделал (см. версию 0.11 во вложении)
Отличия от версии 0.10
1) Вынесена на форму ТЧ ТоварыИзТСДСвернуто
2) Заработал механизм выделения строк без изменения
3) в шапке ТЧ ТоварыИзТСДСвернуто так же добавлены СВОИ команды копирования выделенных строк
4) Убраны с ТЧ ТоварыИзТСД кнопки "выбрать всё/снять выбеление" и колонка "Выбрано"
Вложения
Тип файла: zip УправлениеТСДExt.zip (65.0 Кб, 33 просмотров)
10.03.2016 18:13
KirillHome
 
Только сейчас понял - есть недобработка (когда очищается ТЧ ТоварыИзТСД, но не очищается ТЧ ТоварыИзТСДСвернуты).

Заменить
Код:
&НаКлиенте
Процедура ОчиститьТоварыИзТСД()
	Элементы.ТоварыИзТСД.Доступность = Истина;
	Если Объект.ТоварыИзТСД.Количество() > 0 Тогда
		Объект.ТоварыИзТСД.Очистить(); // т.к. добавляются все товары
		Элементы.ТоварыИзТСД.Обновить();
	КонецЕсли;
	Элементы.ТоварыИзТСД.Доступность = Ложь;
КонецПроцедуры
на
Код:
&НаКлиенте
Процедура ОчиститьТоварыИзТСД()
	Элементы.ТоварыИзТСД.Доступность = Истина;
	Если Объект.ТоварыИзТСД.Количество() > 0 Тогда
		Объект.ТоварыИзТСД.Очистить(); // т.к. добавляются все товары
		Элементы.ТоварыИзТСД.Обновить();
	КонецЕсли;
	Если Объект.ТоварыИзТСДСвернуты.Количество() > 0
		Объект.ТоварыИзТСДСвернуты.Очистить(); //
		Элементы.ТоварыИзТСДСвернуты.Обновить();
	КонецЕсли;
	Элементы.ТоварыИзТСД.Доступность = Ложь;
КонецПроцедуры
11.03.2016 09:37
Tigra_N
 
Привет, KirillHome.
Цитата:
Вроде бы даже разобрался с выделением. Но - есть "засада".
Дело в том, что из ТСД мы получаем строки "не свёрнуто", и, соответственно, так же отображаем.
Получается, что и копировать мы можем "развёрнуто".
я подумал и пришел к выводу, что строки в развернутом виде нам не нужны. я прошелся по всем документам, и ни в каком из них не нужно получать строки в развернутом виде.
Цитата:
Есть совсем дурацкий вариант:
1) Добавить на форму не только ТоварыИзТСД, но и ТоварыИзТСДСвернуто.
2) Разместить кнопки копирования и на одной ТЧ, и на другой.
я просмотрел этот вариант и вот что я предлагаю:
1. сделать невидимым вкладку "ТоварыИзТСД"
2. сделать основной вкладной "ТоварыИзТСДСвернуто", но уже с нормальным названием для пользователя
3. получать строки в свернутом виде и уже работать с полученной ТЧ.
Цитата:
Заработал механизм выделения строк без изменения
этот механизм очень понравился. все так, как я хотел
11.03.2016 10:07
KirillHome
 
Я уже писал, чем мне не нравится отсутствие "развёрнутых" строк.

Пришла мысль - добавить в настройки параметр "Режим отображения прочитанного из ТСД" с тремя вариантами:
"Только свёрнуто"
"Только развёрнуто"
"И свёрнуто, и развёрнуто"

Попробую сегодня сделать, заодно подчистить хвосты.
11.03.2016 11:48
Tigra_N
 
Цитата:
Для контроля "всё или не всё закачалось обработкой" на странице загрузки из ТСД
думаю контролировать не имеет смысла. зачем контролировать? в счет-фактурах, которые приносят с собой поставщики указано количество. если после считывания что-то не совпадет будем разбираться.
Цитата:
Пришла мысль - добавить в настройки параметр "Режим отображения прочитанного из ТСД" с тремя вариантами:
мысль отличная. самый лучший вариант
Цитата:
Попробую сегодня сделать, заодно подчистить хвосты.
что именно? может я почищу, чтобы не отнимать у тебя времени?
11.03.2016 15:06
KirillHome
 
Цитата:
Tigra_N что именно? может я почищу, чтобы не отнимать у тебя времени?
Да какие-то вещи, которые были задуманы, но пропущены.

Ладно, вроде релиз.
Часть логики перенесен из процедуры "ПриСозданииНаСервереExt" в "ПриОткрытии" (при создании ещё не все реквизиты доступны, а при открытии - уже всё).
Для смены версии вызываем "ПроверитьОбновленияНаСервере" (где, в частности, проверяется смена версии).
При смене версии открывается справка и фокус переходит на страницу настроек(увы, на справке не получилось сфокусироваться).
Как и планировалось, добавлена настройка (Реквизит) "КакВыводитьТовары". В зависимости от неё видны вкладки "Товары из ТСД", "Товары из ТСД (сгруппировано)".
На вкладке "Выгружаемые из ТСД товары" добавлена команда "Очистить имеющиеся строки в товарах из ТСД". Смысл в том, что в настройках мы можем сказать "Не очищать ТЧ при создании документа", и очистить её в таком случае можно будет только закрыв и открыв заново форму.

Ну, и на этом, наверное, всё?
Нет, можно ещё много "причёсывать" (к примеру - "не выпускать" с вкладки "Настройки" если не всё заполнено, или что-то заполнено неверно; запомнить не только птички "отображать операцию" и "сворачивать строки для операции" но и имя и синоним операции и перезаполнять таблицу операций из метаданных только при смене версии конфигурации; сделать ещё миллион каких-то проверок, и, в зависимости от них делать доступными или нет какие-то действия - и так далее). Но если честно - надоело
Вложения
Тип файла: zip УправлениеТСДExt.zip (66.8 Кб, 40 просмотров)
11.03.2016 17:53
Tigra_N
 
Цитата:
Но если честно - надоело
я думал тебе надоест еще месяц назад, но ты выдержал больше, чем я ожидал.
Цитата:
Ну, и на этом, наверное, всё?
очень надеюсь на это, а то уже неудобно
11.03.2016 18:30
KirillHome
 
Цитата:
Tigra_N очень надеюсь на это, а то уже неудобно
Да ничего страшного.
На самом деле я из этого тоже кое-что получил - поразбирался с механизмами, с которыми раньше не сталкивался.

Как проверишь - отпишись - "всё" или "не всё".


На самом деле есть ещё одно интересное ответвление.
Выбирать не товары для загрузки в ТСД, а документы; передавать их в ТСД с признаком документа, и получать потом уже как "товары для документа".
В общем то, что описано в документации и чуть-чуть поднято в теме.
14.03.2016 17:36
Tigra_N
 
Цитата:
Да ничего страшного.
На самом деле я из этого тоже кое-что получил - поразбирался с механизмами, с которыми раньше не сталкивался.
я очень рад, что ты тоже получил какую-то пользу.

Цитата:
Как проверишь - отпишись - "всё" или "не всё".
вроде бы проверил. поэтому "вроде" все.
Цитата:
На самом деле есть ещё одно интересное ответвление.
Выбирать не товары для загрузки в ТСД, а документы; передавать их в ТСД с признаком документа, и получать потом уже как "товары для документа".
В общем то, что описано в документации и чуть-чуть поднято в теме.
я понял о чем ты говоришь, но для реализации этого механизма потребуется больше времени и сил. а я уже не могу тебя об этом просить. может в дальнейшем понадобиться, но это уже совсем другая тема.


Опции темы


Часовой пояс GMT +3, время: 06:59.

 

Форум сделан на основе vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.