[ОТВЕТИТЬ]
Опции темы
19.03.2010 12:24  
Назым
Цитата:
Сообщение от Mtirt
Приведи полностью строку подключения.
Вот полная строка..............

Цитата:
DRIVER={MySQL ODBC 3.51 Driver};OPTION=3;DATABASE=UKM_Server;PORT=3306;SERVER=192.168.1.102;UID=root
 
19.03.2010 12:26  
Mtirt
а если добавить PWD='';
 
19.03.2010 12:35  
Назым
Цитата:
Сообщение от Mtirt
а если добавить PWD='';
Поменял. Результат тот же

Цитата:
"DRIVER={MySQL ODBC 3.51 Driver};OPTION=3;DATABASE=UKM_Server;PORT=3306;SERVER=192.168.1.102;UID=root;PWD="
 
19.03.2010 12:37  
Mtirt
Меня смущает название базы. Я всегда считала, что база называется ukmserver.
А у тебя там зачем-то подчеркивание...
 
19.03.2010 12:38  
kadr
А любым клиентом для MySQL ты можешь подключиться к базе под указанным пользовтаелем? Ну это чтобы понять траблы в ODBC драйвере или все же в мускуле запрещен доступ пользователю
 
19.03.2010 13:58  
Назым
Попытался подключиться клиентом. Пишет то же самое
Цитата:
An error occured while performing the operation:
An error occured while establishing the connection:
Type: java.sql.SQLException Error Code: 1044 SQL State: 42000
Message:
Access denied for user 'root'@'%' to database 'ukm_server'
 
19.03.2010 13:59  
Mtirt
ИМЯ БАЗЫ?
Выше я написала - UKMSERVER
 
19.03.2010 14:03  
Назым
Цитата:
Сообщение от Mtirt
ИМЯ БАЗЫ?
Выше я написала - UKMSERVER
Прости, Mtirt. Я почему-то уперся, будучи уверенным, что у меня база так называется. Написал имя базы UKMSERVER. Подключение прошло успешно
 
19.03.2010 14:04  
Mtirt
Успешно и из 1с и из любого клиента?
 
19.03.2010 14:09  
Назым
УРА! Добился. Неправильно было указано имя базы. Вот результирующий текст

Цитата:
ТекстЗапроса = "Select * from trm_in_classifclients";

/// ADODB соединение надо чтоб драйвер был именно 3.51
СтрокаСоединения = "DRIVER={MySQL ODBC 3.51 Driver};OPTION=3;DATABASE=UKMServer;PORT=3306;SERVER=192.168.1.102;UID=root;PWD=";
SQL = new COMОбъект("ADODB.Connection");
SQL.ConnectionString = СтрокаСоединения;
Попытка SQL.Open() Исключение Сообщить(ОписаниеОшибки());возврат;
КонецПопытки;

SQLcmd = New COMОбъект("ADODB.Command");
SQLcmd.ActiveConnection = SQL;
SQLcmd.CommandText = ТекстЗапроса;
тз = Новый ТаблицаЗначений;
мойЗапрос = Новый COMОбъект("ADODB.Recordset");
мойЗапрос.Open(SQLcmd);
КолвоКолонок = мойЗапрос.Fields.Count();


для ш = 0 По КолвоКолонок-1 Цикл
Если тз.Колонки.Найти(мойЗапрос.Fields.Item(ш).name) = Неопределено Тогда
тз.Колонки.Добавить(мойЗапрос.Fields.Item(ш).name);
КонецЕсли;
конецЦикла;
Пока не мойЗапрос.Eof() Цикл
Стр = тз.Добавить();
для ш = 0 По КолвоКолонок-1 Цикл
Стр[мойЗапрос.Fields.Item(ш).name] = мойЗапрос.Fields.Item(ш).value;
КонецЦикла;
мойЗапрос.MoveNext();
КонецЦикла;
мойЗапрос.Close();
Вот только кириллицу не понимает. Вместо русских символов в ТЗ вопросики (?)
 
 


Опции темы



Часовой пояс GMT +3, время: 03:02.

Все в прочитанное - Календарь - RSS - - Карта - Вверх 👫 Яндекс.Метрика
Форум сделан на основе vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. Перевод: zCarot и OlegON
В случае заимствования информации гипертекстовая индексируемая ссылка на Форум обязательна.